summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD11
3 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1029da5c6a3f..8de483967938 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,35 @@
pkgbase = python-moviepy
pkgdesc = Video editing with Python
- pkgver = 1.0.0
- pkgrel = 2
+ pkgver = 1.0.3
+ pkgrel = 4
url = https://zulko.github.io/moviepy/
arch = any
license = MIT
makedepends = python-setuptools
depends = python
depends = ffmpeg
- depends = imagemagick
depends = opencv
depends = python-decorator
depends = python-numpy
depends = python-pillow
- depends = python-scikit-image
- depends = python-scipy
depends = python-tqdm
depends = python-imageio
- source = https://files.pythonhosted.org/packages/source/m/moviepy/moviepy-1.0.0.tar.gz
- sha256sums = 16c7ffca23d90c76dd7b163f648c8166dfd589b7c180b8ff75aa327ae0a2fc6d
+ depends = python-proglog
+ depends = python-imageio-ffmpeg
+ optdepends = python-scikit-image
+ optdepends = python-scipy
+ optdepends = imagemagick
+ source = https://files.pythonhosted.org/packages/source/m/moviepy/moviepy-1.0.3.tar.gz
+ sha256sums = 2884e35d1788077db3ff89e763c5ba7bfddbd7ae9108c9bc809e7ba58fa433f5
pkgname = python-moviepy
depends = python
depends = ffmpeg
- depends = imagemagick
depends = opencv
depends = python-decorator
depends = python-numpy
depends = python-pillow
- depends = python-scikit-image
- depends = python-scipy
depends = python-tqdm
depends = python-imageio
-
+ depends = python-proglog
+ depends = python-imageio-ffmpeg
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4c2c9350f741
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pkg/*
+src/* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 1c5ffdd976eb..16a0c84038ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
pkgbase='python-moviepy'
pkgname=('python-moviepy')
_module='moviepy'
-pkgver='1.0.0'
-pkgrel=2
+pkgver='1.0.3'
+pkgrel=4
pkgdesc="Video editing with Python"
url="https://zulko.github.io/moviepy/"
-depends=('python' 'ffmpeg' 'imagemagick' 'opencv'
- 'python-decorator' 'python-numpy' 'python-pillow' 'python-scikit-image' 'python-scipy' 'python-tqdm' 'python-imageio')
+depends=('python' 'ffmpeg' 'opencv'
+ 'python-decorator' 'python-numpy' 'python-pillow' 'python-tqdm' 'python-imageio' 'python-proglog' 'python-imageio-ffmpeg')
+optdepends=('python-scikit-image' 'python-scipy' 'imagemagick')
makedepends=('python-setuptools')
license=('MIT')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('16c7ffca23d90c76dd7b163f648c8166dfd589b7c180b8ff75aa327ae0a2fc6d')
+sha256sums=('2884e35d1788077db3ff89e763c5ba7bfddbd7ae9108c9bc809e7ba58fa433f5')
build() {
cd "${srcdir}/${_module}-${pkgver}"