summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD20
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ababa7a25166
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-moviepy
+ pkgdesc = Script-based movie editing with python
+ pkgver = 0.2.2
+ pkgrel = 1
+ url = http://zulko.github.io/moviepy/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = ffmpeg
+ depends = imagemagick
+ depends = opencv
+ depends = python-decorator
+ depends = python-numpy
+ depends = python-pillow
+ depends = python-scikit-image
+ depends = python-scipy
+ depends = python-tqdm
+ provides = python-moviepy-git
+ conflicts = python-moviepy-git
+ source = https://pypi.python.org/packages/source/m/moviepy/moviepy-0.2.2.tar.gz
+ sha256sums = 7211b27da68a5cd21dd7d1f03131181287a82060fbccdbb72b22337bcc204186
+
+pkgname = python-moviepy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b39e421174c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+_pkgname=moviepy
+pkgname=python-${_pkgname}
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Script-based movie editing with python"
+arch=('any')
+url="http://zulko.github.io/moviepy/"
+license=("MIT")
+makedepends=('python-setuptools')
+depends=('ffmpeg' 'imagemagick' 'opencv'
+ 'python-decorator' 'python-numpy' 'python-pillow' 'python-scikit-image' 'python-scipy' 'python-tqdm')
+provides=('python-moviepy-git')
+conflicts=('python-moviepy-git')
+source=(https://pypi.python.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz)
+sha256sums=('7211b27da68a5cd21dd7d1f03131181287a82060fbccdbb72b22337bcc204186')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+} \ No newline at end of file