summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77e5d552025a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-mpd2-git
+ pkgdesc = Python MPD client library
+ pkgver = 20130625
+ pkgrel = 1
+ url = http://github.com/Mic92/python-mpd2
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-distribute
+ depends = python
+ provides = python-mpd2
+ conflicts = python-mpd2
+ source = git+https://github.com/Mic92/python-mpd2.git
+ sha1sums = SKIP
+
+pkgname = python-mpd2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..488b272cfdd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jörg Thalheim <joerg@higgsboson.tk
+# Contributor: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+# Contributor: Peter Richard Lewis <plewis@aur.archlinux.org>
+# Contributor: Wieland Hoffmann <the_mineo@web.de>
+# Contributor: stonecrest <stonecrest[at]gmail[dot]com>
+
+pkgname='python-mpd2-git'
+pkgrel=1
+pkgver=20130625
+pkgdesc="Python MPD client library"
+depends=('python')
+conflicts=('python-mpd2')
+provides=('python-mpd2')
+url="http://github.com/Mic92/python-mpd2"
+makedepends=('git' 'python-distribute')
+license=('GPL3')
+arch=('any')
+sha1sums=('SKIP')
+source=("git+https://github.com/Mic92/python-mpd2.git")
+
+pkgver() {
+ cd "$srcdir/python-mpd2"
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
+package() {
+ cd "$srcdir/python-mpd2"
+ python3 setup.py install --root="$pkgdir/" --optimize=1
+}