summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD11
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51492f273f7e..bd5f2c12dea5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-mpi4py-intel
pkgdesc = Python bindings for the Message Passing Interface compiled with intel mpi
- pkgver = 3.1.5
+ pkgver = 3.1.6
pkgrel = 1
url = https://github.com/mpi4py/mpi4py
arch = x86_64
- license = custom:BSD-2-clause
+ license = BSD-2-Clause
checkdepends = python-pytest
checkdepends = python-numba
makedepends = python-build
@@ -17,7 +17,7 @@ pkgbase = python-mpi4py-intel
provides = python-mpi4py
conflicts = python-mpi4py
options = !emptydirs
- source = mpi4py-3.1.5.tar.gz::https://github.com/mpi4py/mpi4py/archive/3.1.5.tar.gz
- sha512sums = 705f1e88952e78612284c70fd1b11abacd524aeb25a5d8db22f5d94b35446eea9f60d6078619bc12b20dc85dd944ea8b8b5d4b2faeeda7219d2271c685c07df1
+ source = mpi4py-3.1.6.tar.gz::https://github.com/mpi4py/mpi4py/archive/3.1.6.tar.gz
+ sha512sums = e99fa0aab13d8e3d2479880a4c920c621512925c6fa2706e7b46b8c3380ca061c1583be70dc5b94f40bf32c0ac7f4cfb508917429226227c52348548ebe0a0d9
pkgname = python-mpi4py-intel
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..1ddb92f16e44
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[python-mpi4py-intel]
+source = "github"
+github = "mpi4py/mpi4py"
+use_latest_release = "true"
+prefix = "v"
diff --git a/PKGBUILD b/PKGBUILD
index 4249155e9106..238d315be004 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
# Based on python-mpi4py, maintained by Bruno Pagani <archange@archlinux.org> and et.al.
_base=mpi4py
pkgname=python-${_base}-intel
-pkgver=3.1.5
+pkgver=3.1.6
pkgrel=1
pkgdesc="Python bindings for the Message Passing Interface compiled with intel mpi"
arch=(x86_64)
url="https://github.com/${_base}/${_base}"
-license=('custom:BSD-2-clause')
+license=(BSD-2-Clause)
depends=(python intel-oneapi-basekit) # intel-oneapi-dpcpp-cpp
makedepends=(python-build python-installer python-setuptools python-wheel cython0)
checkdepends=(python-pytest python-numba) # python-cupy
@@ -16,7 +16,7 @@ provides=(python-${_base})
conflicts=(python-${_base})
options=(!emptydirs)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
-sha512sums=('705f1e88952e78612284c70fd1b11abacd524aeb25a5d8db22f5d94b35446eea9f60d6078619bc12b20dc85dd944ea8b8b5d4b2faeeda7219d2271c685c07df1')
+sha512sums=('e99fa0aab13d8e3d2479880a4c920c621512925c6fa2706e7b46b8c3380ca061c1583be70dc5b94f40bf32c0ac7f4cfb508917429226227c52348548ebe0a0d9')
build() {
cd ${_base}-${pkgver}
@@ -29,11 +29,6 @@ build() {
}
check() {
- if [ -z "$(ldconfig -p | grep libcuda.so.1)" ]; then
- # We don’t have CUDA by default
- export OMPI_MCA_opal_warn_on_missing_libcuda=0
- fi
-
# This is required starting with OpenMPI 3.0 when trying to run more
# processes than the number of available cores
export OMPI_MCA_rmaps_base_oversubscribe=yes