summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32ccf067fe98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Feb 16 12:19:40 UTC 2018
+pkgbase = python-mpi4py-intel
+ pkgdesc = Python bindings for the Message Passing Interface compiled with intel mpi
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/mpi4py/mpi4py
+ arch = any
+ license = custom
+ makedepends = python-setuptools
+ depends = intel-mpi
+ provides = python-mpi4py
+ conflicts = python-mpi4py
+ options = !emptydirs
+ source = https://github.com/mpi4py/mpi4py/archive/3.0.0.tar.gz
+ sha256sums = 77b05c836a414ca20083d6bb0e2d46c9b22940db73a822062ceb7517250b24ed
+
+pkgname = python-mpi4py-intel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..598c6fded2c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+_modulename=mpi4py-intel
+pkgname=python-$_modulename
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Python bindings for the Message Passing Interface compiled with intel mpi"
+arch=(any)
+url="https://github.com/mpi4py/mpi4py"
+license=('custom')
+groups=()
+depends=('intel-mpi')
+makedepends=('python-setuptools')
+provides=('python-mpi4py')
+conflicts=('python-mpi4py')
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('77b05c836a414ca20083d6bb0e2d46c9b22940db73a822062ceb7517250b24ed')
+package() {
+ cd "$srcdir/mpi4py-$pkgver"
+ export MPICC=mpiicc
+ python setup.py install --root="$pkgdir/" --optimize=1
+}