summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eec4b679b45e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-multicodec
+ pkgdesc = A self-describing multiformat, wraps other formats with self-description.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/py-multicodec
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-setuptools
+ source = https://pypi.io/packages/source/p/py-multicodec/py-multicodec-0.2.1.tar.gz
+ sha256sums = 83021ffe8c0e272d19b5b86bc5b39efa67c8e9f4735ce6cafdbc1ace767ec647
+
+pkgname = python-multicodec
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0c580024a8fa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.zst
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6f9a51601be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: redfish <redfish@galactica.pw>
+
+pkgname=python-multicodec
+_name=py-multicodec
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A self-describing multiformat, wraps other formats with self-description."
+arch=('any')
+url="https://pypi.python.org/pypi/py-multicodec"
+license=('MIT')
+depends=('python'
+ 'python-setuptools'
+ )
+checkdepends=()
+source=("https://pypi.io/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
+sha256sums=('83021ffe8c0e272d19b5b86bc5b39efa67c8e9f4735ce6cafdbc1ace767ec647')