summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8fa6cf1db45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-music-tag
+ pkgdesc = Simple interface to edit audio file metadata
+ pkgver = 0.4.3
+ pkgrel = 1
+ url = https://github.com/KristoforMaynard/music-tag
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/m/music-tag/music-tag-0.4.3.tar.gz
+ sha256sums = 0aab6e6eeda8df0f5316ec2d2190bd74561b7e03562ab091ce8d5687cdbcfff6
+
+pkgname = python-music-tag
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f038ada54e0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Malte Jürgens <maltejur@dismail.de>
+
+pkgname=python-music-tag
+_name=${pkgname#python-}
+pkgver=0.4.3
+pkgrel=1
+pkgdesc="Simple interface to edit audio file metadata"
+arch=("x86_64")
+url="https://github.com/KristoforMaynard/music-tag"
+license=("MIT")
+depends=(python)
+makedepends=(python-setuptools)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=("0aab6e6eeda8df0f5316ec2d2190bd74561b7e03562ab091ce8d5687cdbcfff6")
+
+build() {
+ cd $_name-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $_name-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}