summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b1fc346eea4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-mutovis-analysis
+ pkgdesc = Python QT batch curve fitting GUI tool for solar cell IV data files
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/mutovis/analysis-software
+ arch = any
+ license = GPL-3.0
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-scipy
+ depends = python-h5py
+ depends = python-sympy
+ depends = python-mpmath
+ depends = python-lmfit
+ depends = python-dill
+ depends = python-pyqt5
+ source = https://github.com/mutovis/analysis-software/archive/v3.0.0.tar.gz
+ sha256sums = 8718dde2567cb52a6503df04ccb09f9cbc168e33a6f936600e956b064cb05684
+
+pkgname = python-mutovis-analysis
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72a3ed3fe6e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12ed75cd7300
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=python-mutovis-analysis
+_pkgname=analysis-software
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Python QT batch curve fitting GUI tool for solar cell IV data files"
+arch=('any')
+url=https://github.com/mutovis/analysis-software
+license=('GPL-3.0')
+depends=('python' 'python-numpy' 'python-matplotlib' 'python-scipy' 'python-h5py' 'python-sympy' 'python-mpmath' 'python-lmfit' 'python-dill' 'python-pyqt5')
+makedepends=('python-setuptools')
+source=("https://github.com/mutovis/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('8718dde2567cb52a6503df04ccb09f9cbc168e33a6f936600e956b064cb05684')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:ts=2:sw=2:et: