summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75bac135787a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-mypy-zope
+ pkgdesc = Plugin for mypy to support zope.interface
+ pkgver = 0.2.8
+ pkgrel = 1
+ url = https://pypi.org/project/mypy-zope/
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ checkdepends = python-lxml
+ depends = python
+ depends = python-setuptools
+ depends = mypy
+ depends = python-zope-interface
+ depends = python-zope-schema
+ source = https://files.pythonhosted.org/packages/source/m/mypy-zope/mypy-zope-0.2.8.tar.gz
+ sha256sums = 782beeda908878cc47167dec95abd9074f64d5f6dee98fad400966ec07225741
+
+pkgname = python-mypy-zope
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..574a8578368c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src
+/pkg
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d49f5005187
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Marcus Hoffmann <bubu@bubu1.eu>
+
+_pkgname=mypy-zope
+pkgname=python-mypy-zope
+pkgver=0.2.8
+pkgrel=1
+pkgdesc="Plugin for mypy to support zope.interface"
+arch=('any')
+url="https://pypi.org/project/mypy-zope/"
+license=('MIT')
+depends=('python' 'python-setuptools' 'mypy' 'python-zope-interface' 'python-zope-schema')
+checkdepends=('python-pytest' 'python-lxml')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('782beeda908878cc47167dec95abd9074f64d5f6dee98fad400966ec07225741')
+
+# Tests only work with installed package:
+# https://github.com/Shoobx/mypy-zope/issues/25
+#check() {
+# cd $srcdir/${_pkgname}-${pkgver}
+# PYTHONPATH=./build/lib pytest
+# # No idea how to get that to work...
+# #mypy ./src/mypy_zope --strict
+#}
+
+build() {
+ cd $srcdir/${_pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${_pkgname}-${pkgver}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python3 setup.py install --root "${pkgdir}" --optimize=1 --skip-build
+}