summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e3a27a3d235..3ab8b94a7110 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,9 @@ pkgbase = python-netfilterqueue-git
url = https://github.com/kti/python-netfilterqueue
arch = any
license = GPL2
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = cython
depends = libnetfilter_queue
diff --git a/PKGBUILD b/PKGBUILD
index d6c60081adfc..d26f2fb7ec71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@ arch=('any')
url="https://github.com/kti/python-netfilterqueue"
license=("GPL2")
depends=('python' 'cython' 'libnetfilter_queue')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("${_pkgbase}::git+https://github.com/kti/python-netfilterqueue")
sha256sums=('SKIP')
@@ -21,10 +22,12 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgbase}"
- python setup.py build
+ #python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${_pkgbase}"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ #python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}