summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c064dff7237
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-nifty-git
+ pkgdesc = Versatile library designed to enable the development of signal inference algorithms that operate regardless of the underlying grids (spatial, spectral, temporal, ...) and their resolutions
+ pkgver = 5.0.1.r174.g12c5065b
+ pkgrel = 1
+ url = http://ift.pages.mpcdf.de/nifty/ift.html
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ depends = python-scipy
+ depends = python-pypocketfft
+ optdepends = python-pyhealpix: harmonic transforms involving domains on the sphere
+ optdepends = python-nifty_gridder: radio interferometry responses
+ optdepends = python-mpi4py: MPI-parallel execution
+ optdepends = python-matplotlib: field plotting
+ provides = python-nifty=5.0.1.r174.g12c5065b
+ conflicts = python-nifty
+ source = python-nifty-git::git+https://gitlab.mpcdf.mpg.de/ift/nifty.git
+ sha512sums = SKIP
+
+pkgname = python-nifty-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb2697bb1f5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gordian Edenhofer <gordian.edenhofer@gmail.com>
+
+pkgname=python-nifty-git
+_pkgname=nifty
+pkgver=5.0.1.r174.g12c5065b
+pkgrel=1
+pkgdesc="Versatile library designed to enable the development of signal inference algorithms that operate regardless of the underlying grids (spatial, spectral, temporal, ...) and their resolutions"
+arch=('any')
+license=('GPL3')
+url="http://ift.pages.mpcdf.de/nifty/ift.html"
+depends=('python' 'python-scipy' 'python-pypocketfft')
+optdepends=("python-pyhealpix: harmonic transforms involving domains on the sphere"
+ "python-nifty_gridder: radio interferometry responses"
+ "python-mpi4py: MPI-parallel execution"
+ "python-matplotlib: field plotting")
+makedepends=('python-setuptools' 'git')
+provides=("python-nifty=${pkgver}")
+conflicts=('python-nifty')
+source=("${pkgname}"::"git+https://gitlab.mpcdf.mpg.de/ift/${_pkgname}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' \
+ || printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py clean
+ rm -rf build dist
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}