summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c03a6516d38e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Feb 19 12:23:03 UTC 2016
+pkgbase = python-numba-git
+ pkgdesc = A lightweight LLVM python binding for writing JIT compilers
+ pkgver = 0.22.1.r574.g77d6a60
+ pkgrel = 1
+ url = https://github.com/numba/numba
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = cython
+ depends = python
+ depends = python-llvmlite-git
+ provides = python-numba
+ source = numba::git+https://github.com/numba/numba.git
+ md5sums = SKIP
+
+pkgname = python-numba-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0829fcfd226b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
+# Contributor: Michael Schubert <mschu.dev at gmail>
+
+pkgname=(python-numba-git)
+_gitname=numba
+pkgver=0.22.1.r574.g77d6a60
+pkgrel=1
+pkgdesc="A lightweight LLVM python binding for writing JIT compilers"
+url="https://github.com/numba/numba"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('python' 'python-llvmlite-git' )
+makedepends=('git' 'cython')
+conflicts=()
+replaces=()
+backup=()
+provides=(python-numba)
+source=(${_gitname}::git+https://github.com/numba/numba.git)
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd numba
+ git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/numba"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/numba"
+ python setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
+}