summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 164ab99086d6..37514d96dd45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
pkgbase = python-obspy-docs
pkgdesc = Set of HTML documentation for Obspy seismological framework.
- pkgver = 1.2.0
+ pkgver = 1.3.0
pkgrel = 1
url = http://docs.obspy.org
arch = any
license = LGPL
+ makedepends = python-cartopy
+ makedepends = python-obspy
+ makedepends = python-m2r2
+ makedepends = python-matplotlib
+ makedepends = python-sphinx
+ makedepends = python-sphinx_rtd_theme
options = docs
- source = http://docs.obspy.org/archive/obspy-1.2.0-documentation.tgz
- sha256sums = aacb0b14f0c9955f5592b7858ea455e1d02d91fab3ba7f74f11b800daeb681a9
+ source = python-obspy-1.3.0.tar.gz::https://github.com/obspy/obspy/archive/1.3.0.tar.gz
+ sha256sums = 12a5ba9cae3445c9f31bd0e0561e791bc755cc627d4412f851f6286fef82be34
pkgname = python-obspy-docs
-
diff --git a/PKGBUILD b/PKGBUILD
index fecc5c669248..edb4ef2ef680 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,25 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=python-obspy-docs
-pkgver=1.2.0
+pkgver=1.3.0
pkgrel=1
pkgdesc='Set of HTML documentation for Obspy seismological framework.'
arch=('any')
url='http://docs.obspy.org'
license=('LGPL')
options=('docs')
-source=(http://docs.obspy.org/archive/obspy-${pkgver}-documentation.tgz)
-sha256sums=('aacb0b14f0c9955f5592b7858ea455e1d02d91fab3ba7f74f11b800daeb681a9')
+makedepends=('python-cartopy' 'python-obspy' 'python-m2r2' 'python-matplotlib' 'python-sphinx' 'python-sphinx_rtd_theme')
+source=("${pkgname%-docs}-${pkgver}.tar.gz::https://github.com/obspy/obspy/archive/${pkgver}.tar.gz")
+sha256sums=('12a5ba9cae3445c9f31bd0e0561e791bc755cc627d4412f851f6286fef82be34')
+
+build() {
+ cd "obspy-${pkgver}/misc/docs"
+ mkdir _build
+ sphinx-build -a -E -j auto -b html source _build
+}
package() {
+ cd "obspy-${pkgver}/misc/docs"
install -d ${pkgdir}/usr/share/doc/python-obspy
- cp -a obspy-${pkgver}-documentation ${pkgdir}/usr/share/doc/python-obspy/html
+ cp -a _build ${pkgdir}/usr/share/doc/python-obspy/html
}
# vim:set ts=4 sw=4 et: