summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD20
3 files changed, 26 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94e02700d230..b5deba424cb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = python-oct2py
pkgdesc = Python to GNU Octave bridge --> run m-files from python
- pkgver = 5.6.0
+ pkgver = 5.6.1
pkgrel = 1
url = http://github.com/blink1073/oct2py
arch = any
license = MIT
+ checkdepends = python-pytest-timeout
+ checkdepends = octave-signal
+ checkdepends = python-pandas
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
@@ -13,10 +16,8 @@ pkgbase = python-oct2py
depends = python-scipy
depends = jupyter-octave_kernel
depends = gnuplot
- optdepends = python-pytest: for test use
- optdepends = python-pandas: for test use
- optdepends = jupyter-nbconvert: for test use
- source = https://pypi.org/packages/source/o/oct2py/oct2py-5.6.0.tar.gz
- b2sums = e22aca80608e1132f2cb8936e9dac7c97bd8e5463b6997dd80f0ed567af2a59a28b4c58995b11e2c1a970bc0bde81afda432d8ce5306b2eb5417b1f75b8b4b19
+ optdepends = python-pandas: for Pandas DataFrames and Series support
+ source = oct2py-5.6.1.tar.gz::http://github.com/blink1073/oct2py/archive/v5.6.1.tar.gz
+ b2sums = f9d1c04b7ff99399de6d32216eabcc2045c79441ce809754948baf67d6a2d88d3d34b33b83b476376dfe773287c43ee62fa9bd9540c2cf917e659c6e9b12a52c
pkgname = python-oct2py
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..85abc0b05535
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[python-oct2py]
+source = "github"
+github = "blink1073/oct2py"
+use_latest_release = "true"
+prefix = "v" \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index a8843711137d..7f06b2a77dba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Ishan Arora <ishanarora@gmail.com>
_base=oct2py
pkgname=python-${_base}
-pkgver=5.6.0
+pkgver=5.6.1
pkgrel=1
pkgdesc="Python to GNU Octave bridge --> run m-files from python"
arch=(any)
@@ -11,17 +11,25 @@ url="http://github.com/blink1073/${_base}"
license=(MIT)
depends=(python-scipy jupyter-octave_kernel gnuplot)
makedepends=(python-build python-installer python-setuptools python-hatchling python-wheel)
-optdepends=('python-pytest: for test use'
- 'python-pandas: for test use'
- 'jupyter-nbconvert: for test use')
-source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
-b2sums=('e22aca80608e1132f2cb8936e9dac7c97bd8e5463b6997dd80f0ed567af2a59a28b4c58995b11e2c1a970bc0bde81afda432d8ce5306b2eb5417b1f75b8b4b19')
+checkdepends=(python-pytest-timeout octave-signal python-pandas) # jupyter-nbconvert
+optdepends=('python-pandas: for Pandas DataFrames and Series support')
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+b2sums=('f9d1c04b7ff99399de6d32216eabcc2045c79441ce809754948baf67d6a2d88d3d34b33b83b476376dfe773287c43ee62fa9bd9540c2cf917e659c6e9b12a52c')
build() {
cd ${_base}-${pkgver}
python -m build --wheel --skip-dependency-check --no-isolation
}
+check() {
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest \
+ --ignore=tests/test_usage.py \
+ -k 'not deprecated_return_both'
+}
+
package() {
cd ${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl