summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a44ee1fc2e2..23d4522ee326 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
pkgbase = python-ofxclient-git
pkgdesc = Simple ofxclient command line utility and OFX client libraries for development.
pkgver = 2.0.4.r0.g4da2719
- pkgrel = 1
+ pkgrel = 5
url = https://github.com/captin411/ofxclient
arch = x86_64
arch = i686
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python>=3.7
depends = python-beautifulsoup4
- depends = ofxparse
- depends = ofxhome
+ depends = python-ofxhome
depends = python-keyring
depends = python-configargparse
depends = python-ofxparse
provides = ofxclient
+ provides = python-ofxclient
conflicts = ofxclient
+ conflicts = python-ofxclient
source = ofxclient::git+https://github.com/captin411/ofxclient.git#branch=master
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d33ee4457a29..b099ec0fd3da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
-# Maintainer: lothar_m <lothar_m at riseup dot net>
+# Maintainer: Mathieu <mathieu@clabaut.net>
_pkgname=ofxclient
pkgname=python-ofxclient-git
pkgver=2.0.4.r0.g4da2719
-pkgrel=1
+pkgrel=5
pkgdesc="Simple ofxclient command line utility and OFX client libraries for development."
arch=('x86_64' 'i686')
url="https://github.com/captin411/ofxclient"
license=('MIT')
depends=('python>=3.7'
'python-beautifulsoup4'
- 'ofxparse'
- 'ofxhome'
+ 'python-ofxhome'
'python-keyring'
'python-configargparse'
'python-ofxparse'
)
-# makedepends=()
-provides=(ofxclient)
-conflicts=(ofxclient)
+makedepends=(python-build python-installer python-wheel)
+provides=(ofxclient python-ofxclient)
+conflicts=(ofxclient python-ofxclient)
source=('ofxclient::git+https://github.com/captin411/ofxclient.git#branch=master')
md5sums=('SKIP')
@@ -30,13 +29,12 @@ pkgver() {
}
build() {
- cd "$srcdir/$_pkgname"
- python setup.py build
+ cd "$_pkgname"
+ python -m build --wheel --no-isolation
}
package() {
- # install package
- cd "$srcdir/$_pkgname"
- python setup.py install --root="$pkgdir/"
+ cd "$_pkgname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}