summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ececdf5c9562..abaf225537bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-onnx
pkgdesc = Open Neural Network Exchange
pkgver = 1.6.0
- pkgrel = 7
+ pkgrel = 8
url = https://onnx.ai
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index ad8ad4d86d66..80c9a053e1a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-onnx
pkgver=1.6.0
-pkgrel=7
+pkgrel=8
pkgdesc='Open Neural Network Exchange'
arch=('x86_64')
url='https://onnx.ai'
@@ -41,6 +41,8 @@ get_pyver() {
prepare() {
cd "${srcdir}/${pkgname}"
git submodule update --init --recursive
+ # fix build with protobuf 3.11, see https://github.com/onnx/onnx/pull/2482/files
+ sed -i 's/${ONNX_DLLEXPORT_STR}${CMAKE_CURRENT_BINARY_DIR})/${CMAKE_CURRENT_BINARY_DIR})/' "${srcdir}/${pkgname}/CMakeLists.txt"
}
build() {