summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--build-fixes.patch6
3 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 329efab82a69..14d4e7757087 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-onnxruntime
pkgdesc = Cross-platform, high performance scoring engine for ML models
- pkgver = 0.4.0
- pkgrel = 2
+ pkgver = 0.5.0
+ pkgrel = 1
url = https://github.com/microsoft/onnxruntime
arch = x86_64
license = MIT
@@ -17,7 +17,7 @@ pkgbase = python-onnxruntime
depends = protobuf
depends = re2
depends = python-numpy
- source = git+https://github.com/microsoft/onnxruntime#tag=v0.4.0
+ source = git+https://github.com/microsoft/onnxruntime#tag=v0.5.0
source = git+https://github.com/HowardHinnant/date.git
source = eigen::git+https://github.com/eigenteam/eigen-git-mirror.git
source = git+https://github.com/google/gemmlowp.git
@@ -32,7 +32,7 @@ pkgbase = python-onnxruntime
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = 4901a35f1c8687555c63aaa9d0dddab9becd59b4779dd1040c19bb7dcf690773df103cffac94228f7019644d0cca03c09df525b8188fc3eef65557af07e25a26
+ sha512sums = c598f14c413c35e923e76770214f464922431255b8b0a5e2ff7851b3447f8af7ee2d0f1349aa63d251097902bd6a506626dabc3a8e7f2a63144a1be5478e5470
pkgname = python-onnxruntime
@@ -42,6 +42,6 @@ pkgname = python-onnxruntime-cuda
depends = python-numpy
depends = cuda
depends = cudnn
- provides = python-onnxruntime=0.4.0
+ provides = python-onnxruntime=0.5.0
conflicts = python-onnxruntime
diff --git a/PKGBUILD b/PKGBUILD
index a235cd51fe0b..d6c8dda8217b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
pkgbase=python-onnxruntime
pkgname=(python-onnxruntime python-onnxruntime-cuda)
-pkgver=0.4.0
+pkgver=0.5.0
pkgdesc='Cross-platform, high performance scoring engine for ML models'
-pkgrel=2
+pkgrel=1
arch=(x86_64)
url='https://github.com/microsoft/onnxruntime'
license=(MIT)
@@ -30,7 +30,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '4901a35f1c8687555c63aaa9d0dddab9becd59b4779dd1040c19bb7dcf690773df103cffac94228f7019644d0cca03c09df525b8188fc3eef65557af07e25a26')
+ 'c598f14c413c35e923e76770214f464922431255b8b0a5e2ff7851b3447f8af7ee2d0f1349aa63d251097902bd6a506626dabc3a8e7f2a63144a1be5478e5470')
prepare() {
cd onnxruntime
diff --git a/build-fixes.patch b/build-fixes.patch
index 7276d69d9d4d..e061f592bdb4 100644
--- a/build-fixes.patch
+++ b/build-fixes.patch
@@ -43,7 +43,7 @@ index 96c89fef..0e37e487 100644
# TVM
if (onnxruntime_USE_TVM)
-@@ -620,11 +605,10 @@ if (onnxruntime_BUILD_UNIT_TESTS)
+@@ -620,15 +605,10 @@ if (onnxruntime_BUILD_UNIT_TESTS)
# turned ON by the previous step when building a shared lib
set(CMAKE_SKIP_BUILD_RPATH OFF)
# gtest and gmock
@@ -52,6 +52,10 @@ index 96c89fef..0e37e487 100644
- set_target_properties(gmock_main PROPERTIES FOLDER "External/GTest")
- set_target_properties(gtest PROPERTIES FOLDER "External/GTest")
- set_target_properties(gtest_main PROPERTIES FOLDER "External/GTest")
+- if(UNIX)
+- target_compile_options(gmock PRIVATE "-w")
+- target_compile_options(gtest PRIVATE "-w")
+- endif()
+ pkg_check_modules(GTEST REQUIRED IMPORTED_TARGET GLOBAL gtest)
+ pkg_check_modules(GMOCK REQUIRED IMPORTED_TARGET GLOBAL gmock)
+ add_library(gtest ALIAS PkgConfig::GTEST)