summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
-rw-r--r--build-fixes.patch8
3 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c9b3f410ec7..3db282d38204 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-onnxruntime
pkgdesc = Cross-platform, high performance scoring engine for ML models
- pkgver = 0.5.1
+ pkgver = 1.0.0
pkgrel = 2
url = https://github.com/microsoft/onnxruntime
arch = x86_64
@@ -13,14 +13,14 @@ pkgbase = python-onnxruntime
makedepends = gmock
makedepends = pybind11
makedepends = python-setuptools
+ makedepends = cub
depends = protobuf
depends = re2
depends = python-numpy
- source = git+https://github.com/microsoft/onnxruntime#tag=v0.5.1
+ source = git+https://github.com/microsoft/onnxruntime#tag=v1.0.0
source = git+https://github.com/HowardHinnant/date.git
source = eigen::git+https://github.com/eigenteam/eigen-git-mirror.git
source = git+https://github.com/google/gemmlowp.git
- source = gsl::git+https://github.com/Microsoft/GSL.git
source = git+https://github.com/google/nsync.git
source = git+https://github.com/onnx/onnx.git
source = build-fixes.patch
@@ -30,8 +30,7 @@ pkgbase = python-onnxruntime
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = 14371770514544fbb25016fb6b986501911ca5683584c45855325fa7447dbf8f10735c8d57239996c5ee3dc7cce2a3238150c04564529769c9dcb7edb47e799e
+ sha512sums = da8e27ff0011fb207ee8a6f8675160eb85cb8711f01050fa7454234242af141951cb5bba52fa50b98cf8567b8faa973565dfef37f4daa2219a42cf26e03c86b5
pkgname = python-onnxruntime
@@ -41,6 +40,6 @@ pkgname = python-onnxruntime-cuda
depends = python-numpy
depends = cuda
depends = cudnn
- provides = python-onnxruntime=0.5.1
+ provides = python-onnxruntime=1.0.0
conflicts = python-onnxruntime
diff --git a/PKGBUILD b/PKGBUILD
index 33a2035fde49..181ac81b0bc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgbase=python-onnxruntime
pkgname=(python-onnxruntime python-onnxruntime-cuda)
-pkgver=0.5.1
+pkgver=1.0.0
pkgdesc='Cross-platform, high performance scoring engine for ML models'
pkgrel=2
arch=(x86_64)
url='https://github.com/microsoft/onnxruntime'
license=(MIT)
depends=(protobuf re2 python-numpy)
-makedepends=(git cmake cuda cudnn gtest gmock pybind11 python-setuptools)
+makedepends=(git cmake cuda cudnn gtest gmock pybind11 python-setuptools cub)
# not de-vendored libraries
# eigen: API changes a lot since extra/eigen 3.3.7 to the commit onnxruntime uses
# onnx: onnxruntime requires headers, which are not installed in python-onnx
@@ -17,7 +17,6 @@ source=("git+https://github.com/microsoft/onnxruntime#tag=v$pkgver"
"git+https://github.com/HowardHinnant/date.git"
"eigen::git+https://github.com/eigenteam/eigen-git-mirror.git"
"git+https://github.com/google/gemmlowp.git"
- "gsl::git+https://github.com/Microsoft/GSL.git"
"git+https://github.com/google/nsync.git"
"git+https://github.com/onnx/onnx.git"
build-fixes.patch)
@@ -27,8 +26,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- '14371770514544fbb25016fb6b986501911ca5683584c45855325fa7447dbf8f10735c8d57239996c5ee3dc7cce2a3238150c04564529769c9dcb7edb47e799e')
+ 'da8e27ff0011fb207ee8a6f8675160eb85cb8711f01050fa7454234242af141951cb5bba52fa50b98cf8567b8faa973565dfef37f4daa2219a42cf26e03c86b5')
prepare() {
cd onnxruntime
@@ -39,7 +37,7 @@ prepare() {
patch -Np1 -i ../build-fixes.patch
git submodule init
- for mod in date eigen gemmlowp gsl nsync onnx ; do
+ for mod in date eigen gemmlowp nsync onnx ; do
git config submodule.cmake/external/$mod.url "$srcdir"/$mod
git submodule update cmake/external/$mod
done
diff --git a/build-fixes.patch b/build-fixes.patch
index be8a75d6b2a8..2ab78eb750a2 100644
--- a/build-fixes.patch
+++ b/build-fixes.patch
@@ -26,20 +26,20 @@ index 96c89fef..0e37e487 100644
@@ -282,8 +274,6 @@ set(ONNXRUNTIME_INCLUDE_DIR ${REPO_ROOT}/include/onnxruntime)
+ set(ONNXRUNTIME_INCLUDE_DIR ${REPO_ROOT}/include/onnxruntime)
add_subdirectory(external/date EXCLUDE_FROM_ALL)
- add_subdirectory(external/gsl EXCLUDE_FROM_ALL)
-add_subdirectory(external/re2 EXCLUDE_FROM_ALL)
-set_target_properties(re2 PROPERTIES FOLDER "External/re2")
- add_library(gsl ALIAS GSL)
# bounds checking behavior.
+ # throw instead of calling terminate if there's a bounds checking violation.
@@ -306,7 +296,7 @@ function(onnxruntime_add_include_to_target dst_target)
endforeach()
endfunction()
--set(onnxruntime_EXTERNAL_DEPENDENCIES gsl onnx_proto re2)
-+set(onnxruntime_EXTERNAL_DEPENDENCIES gsl onnx_proto)
+-set(onnxruntime_EXTERNAL_DEPENDENCIES onnx_proto re2)
++set(onnxruntime_EXTERNAL_DEPENDENCIES onnx_proto)
# TVM
if (onnxruntime_USE_TVM)