summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD22
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5d86af7d083
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-openchemistrypy-git
+ pkgdesc = OpenChemistry python libraries.
+ pkgver = 0.0.17
+ pkgrel = 1
+ url = https://github.com/OpenChemistry/openchemistrypy
+ arch = any
+ license = BSD 3-Clause
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = avogadro2-git
+ provides = python-openchemistrypy-git
+ conflicts = python-openchemistrypy-git
+ source = git+https://github.com/Openchemistry/openchemistrypy.git#branch=master
+ md5sums = SKIP
+
+pkgname = python-openchemistrypy-git
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58b08b7c1185
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=('python-openchemistrypy-git')
+_srcname='openchemistrypy'
+pkgdesc='OpenChemistry python libraries.'
+pkgver=0.0.17
+pkgrel=1
+arch=('any')
+url="https://github.com/OpenChemistry/${_srcname}"
+license=('BSD 3-Clause')
+
+depends=('python' 'avogadro2-git')
+makedepends=('git' 'python-setuptools')
+provides=("${pkgname[0]%-git}")
+conflicts=("${pkgname[0]%-git}")
+
+source=("${_srcname}::git+${url}.git")
+sha512sums=('SKIP')
+
+package() {
+ cd "${srcdir}/${_srcname}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+}