summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b28311c23c10
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-openems-git
+ pkgdesc = a free and open source EC-FDTD solver
+ pkgver = v0.0.35.r28.g6133dea
+ pkgrel = 1
+ url = https://github.com/thliebig/openEMS
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cython
+ depends = openems
+ provides = python-openems
+ conflicts = python-openems
+ source = git+https://github.com/thliebig/openEMS
+ md5sums = SKIP
+
+pkgname = python-openems-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b06d11a3081
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Stefan Biereigel <stefan@biereigel.de>
+
+pkgname=python-openems-git
+pkgver=v0.0.35.r28.g6133dea
+pkgrel=1
+pkgdesc="a free and open source EC-FDTD solver"
+url="https://github.com/thliebig/openEMS"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('openems' 'python-csxcad')
+makedepends=('cython')
+provides=('python-openems')
+conflicts=('python-openems')
+
+source=(git+https://github.com/thliebig/openEMS)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/openEMS"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/openEMS/python"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/openEMS/python"
+ python setup.py install --root=${pkgdir}
+}