summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6e0b52e7542..cd226ff62e68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Sameer Puri <purisame@spuri.io>
pkgname=python-or-tools
-pkgver=8.1
+pkgver=8.2
pkgrel=1
pkgdesc="Google's Operations Research tools"
arch=('x86_64' 'i686' 'aarch64' 'armv7h')
url="https://github.com/google/or-tools"
license=('Apache2')
-depends=('python>=3.5' 'swig' 'python-protobuf')
+depends=('python>=3.6' 'swig' 'python-protobuf')
makedepends=('cmake' 'wget' 'lsb-release' 'automake' 'python-wheel' 'python-pip' 'git')
+optdepends=('cplex: CPLEX solver support')
options=(!emptydirs)
source=("https://github.com/google/or-tools/archive/v${pkgver}.tar.gz")
-sha384sums=('a42a075761ee4411e5d3d55eff36c4e01b1e3a9f6bcca720c2189c9fb5181ee48b3d18a0424a304ef70a6f289f6d1bee')
+sha384sums=('e5fdd4b5a40442fdafe48e677d8c45dc27d64f70bb42d508dd90e4ca64fed54be5954b3a29b9c460552287911d45bacd')
build() {
cd "${srcdir}/or-tools-${pkgver}"