summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ac6272ea7e0..9860f3eac9c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
# Generated by mksrcinfo v8
-# Sat Dec 23 13:45:47 UTC 2017
+# Wed May 23 00:45:50 UTC 2018
pkgbase = python-pandas-docs
pkgdesc = Documentation for Python Pandas module.
- pkgver = 0.21.1
+ pkgver = 0.23.0
pkgrel = 1
url = http://pandas.pydata.org
arch = any
license = BSD
- makedepends = unzip
- noextract = python-pandas-docs-0.21.1.zip
- source = python-pandas-docs-0.21.1.zip::http://pandas.pydata.org/pandas-docs/stable/pandas.zip
- sha256sums = 77f7ebd4ce49608315830ab84583fea0b5b37c4eb6512e05b18786bbeea41052
+ source = python-pandas-docs-0.23.0.zip::http://pandas.pydata.org/pandas-docs/stable/pandas.zip
+ sha256sums = 0c11cde5b842a448a3b1cf169e83748d04dfa21013111dd4c3196650c3536efc
pkgname = python-pandas-docs
diff --git a/PKGBUILD b/PKGBUILD
index ae453ea7e269..c017111cc3f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,21 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=python-pandas-docs
-pkgver=0.21.1
+pkgver=0.23.0
pkgrel=1
pkgdesc="Documentation for Python Pandas module."
-makedepends=('unzip')
arch=('any')
url='http://pandas.pydata.org'
license=('BSD')
-source=("$pkgname-$pkgver.zip::http://pandas.pydata.org/pandas-docs/stable/pandas.zip")
-noextract=("$pkgname-$pkgver.zip")
-sha256sums=('77f7ebd4ce49608315830ab84583fea0b5b37c4eb6512e05b18786bbeea41052')
+source=("${pkgname}-${pkgver}.zip::http://pandas.pydata.org/pandas-docs/stable/pandas.zip")
+sha256sums=('0c11cde5b842a448a3b1cf169e83748d04dfa21013111dd4c3196650c3536efc')
-package()
-{
- install -d "$pkgdir/usr/share/doc/python-pandas"
- unzip -qd "$pkgdir/usr/share/doc/python-pandas" "$srcdir/$pkgname-$pkgver.zip"
- find "$pkgdir/usr/share/doc/python-pandas/html" -type d -exec chmod 755 \{\} \;
- find "$pkgdir/usr/share/doc/python-pandas/html" -type f -exec chmod 644 \{\} \;
+prepare() {
+ rm ${pkgname}-${pkgver}.zip
+}
+
+package() {
+ install -d "${pkgdir}"/usr/share/doc/python-pandas/html
+ cp -a ./* "${pkgdir}"/usr/share/doc/python-pandas/html/
}
# vim:set ts=2 sw=2 et: