summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54d955d35d60..52ef894532a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = python-pandas_market_calendars
pkgdesc = Market and exchange trading calendars for pandas
- pkgver = 1.4.0
- pkgrel = 2
+ pkgver = 3.4
+ pkgrel = 1
url = https://github.com/rsheftel/pandas_market_calendars
arch = any
license = MIT
makedepends = python-setuptools
depends = python-pytz
depends = python-pandas
- source = https://files.pythonhosted.org/packages/source/p/pandas_market_calendars/pandas_market_calendars-1.4.0.tar.gz
- sha256sums = adc4425f6c72522efd829d2e0da65ce5961b8ccc60a8fcebee99d7dea2463745
+ depends = python-exchange_calendars
+ source = https://files.pythonhosted.org/packages/source/p/pandas_market_calendars/pandas_market_calendars-3.4.tar.gz
+ sha256sums = d7c8130df56b4628c582bcb924c0c5fe664e6ac401f364296481c0bb6daf77e9
pkgname = python-pandas_market_calendars
-
diff --git a/PKGBUILD b/PKGBUILD
index 96439d20dd19..46165cb843d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Kewl <xrjy@nygb.rh.bet(rot13)>
-pkgname='python-pandas_market_calendars'
+pkgname=python-pandas_market_calendars
_pkgname=${pkgname#python-}
-pkgver=1.4.0
-pkgrel=2
+pkgver=3.4
+pkgrel=1
pkgdesc="Market and exchange trading calendars for pandas"
arch=('any')
-depends=('python-pytz' 'python-pandas')
+depends=('python-pytz' 'python-pandas' 'python-exchange_calendars')
makedepends=('python-setuptools')
url="https://github.com/rsheftel/$_pkgname"
license=('MIT')
source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('adc4425f6c72522efd829d2e0da65ce5961b8ccc60a8fcebee99d7dea2463745')
+sha256sums=('d7c8130df56b4628c582bcb924c0c5fe664e6ac401f364296481c0bb6daf77e9')
build() {
cd $_pkgname-$pkgver
@@ -20,5 +20,5 @@ build() {
package() {
cd $_pkgname-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}