summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD51
-rw-r--r--python-panflute.install14
3 files changed, 34 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a854b95d809..1b27754ffc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = python-panflute
pkgdesc = A Pythonic alternative to John MacFarlane’s pandocfilters
- pkgver = 2.0.5
- pkgrel = 1
+ pkgver = 2.1.1
+ pkgrel = 3
url = https://github.com/sergiocorreia/panflute
- install = python-panflute.install
arch = any
license = BSD
checkdepends = python-pandocfilters
@@ -13,9 +12,10 @@ pkgbase = python-panflute
depends = python
depends = python-click
depends = python-yaml
+ provides = pandoc-panflute=2.1.1
+ conflicts = pandoc-panflute
replaces = pandoc-panflute
- source = python-panflute-2.0.5.tar.gz::https://github.com/sergiocorreia/panflute/archive/2.0.5.tar.gz
- sha256sums = 2c2487bf90c4ef9bf5261a87a5336b58f357a152d6853b18167379568e310db5
+ source = panflute-2.1.1.tar.gz::https://github.com/sergiocorreia/panflute/archive/2.1.1.tar.gz
+ sha256sums = e8c4580f36277ae195dc1614e7cff239d5d3eb0c40ef7e1abb676f6aa2df127c
pkgname = python-panflute
-
diff --git a/PKGBUILD b/PKGBUILD
index 8cd238ba66d..58b881d00dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,42 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
-# Mantainer: Michael M. Tung <mtung at mat dot upv dot es>
+# Maintainer: Michael M. Tung <mtung at mat dot upv dot es>
-_pipname=panflute
-pkgname=python-$_pipname
-pkgver=2.0.5
-pkgrel=1
+_py_name=panflute
+pkgname=python-$_py_name
+pkgver=2.1.1
+pkgrel=3
pkgdesc='A Pythonic alternative to John MacFarlane’s pandocfilters'
-url="https://github.com/sergiocorreia/$_pipname"
-arch=('any')
-license=('BSD')
-_pydeps=('click'
- 'yaml')
-depends=('pandoc>=2.11.0.4' 'python' "${_pydeps[@]/#/python-}")
-makedepends=('python-setuptools')
-replaces=('pandoc-panflute')
-_pycheckdeps=('pandocfilters'
- 'pytest-cov')
-checkdepends=("${_pycheckdeps[@]/#/python-}")
-install=$pkgname.install
-source=("$pkgname-$pkgver.tar.gz::https://github.com/sergiocorreia/$_pipname/archive/$pkgver.tar.gz")
-sha256sums=('2c2487bf90c4ef9bf5261a87a5336b58f357a152d6853b18167379568e310db5')
+url="https://github.com/sergiocorreia/$_py_name"
+arch=(any)
+license=(BSD)
+_pydeps=(click yaml)
+depends=('pandoc>=2.11.0.4' python "${_pydeps[@]/#/python-}")
+makedepends=(python-setuptools)
+_py_checkdeps=(pandocfilters pytest-cov)
+checkdepends=("${_py_checkdeps[@]/#/python-}")
+provides=("pandoc-$_py_name=$pkgver")
+conflicts=("pandoc-$_py_name")
+replaces=(pandoc-panflute)
+_archive="$_py_name-$pkgver"
+source=("$_archive.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('e8c4580f36277ae195dc1614e7cff239d5d3eb0c40ef7e1abb676f6aa2df127c')
+
+prepare() {
+ cd "$_archive"
+ sed -i -e '/click/s/<8/<9/' setup.py
+}
build() {
- cd "$_pipname-$pkgver"
+ cd "$_archive"
python setup.py build
}
check() {
- cd "$_pipname-$pkgver"
+ cd "$_archive"
python setup.py test
}
package() {
- cd "$_pipname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$_archive"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
diff --git a/python-panflute.install b/python-panflute.install
deleted file mode 100644
index 0990db7381e..00000000000
--- a/python-panflute.install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_install() {
- cat <<- EOF 1>&2
- --> WARNING: Panflute is not 100% compatible with Pandoc 2.10+. Most
- --> notibly anything to do with tables is not supported, see upstream
- --> issue here: https://github.com/sergiocorreia/panflute/issues/142
- --> In order to use, please downgrade Pandoc to 2.9.x (one way is to
- --> use a pacman mirror that has an archive of old packages, then add
- --> Pandoc to your HoldPkg list).
- EOF
-}
-
-post_upgrade() {
- post_install
-}