summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD31
2 files changed, 23 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad4849bb37f1..958d0b13c5ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = python-panflute
- pkgdesc = Pythonic Pandoc filters
+ pkgdesc = A Pythonic alternative to John MacFarlane’s pandocfilters
pkgver = 1.12.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sergiocorreia/panflute
arch = any
- license = BSD3
- makedepends = python
+ license = BSD
makedepends = python-pip
+ depends = python
depends = python-click
depends = python-yaml
depends = python-shutilwhich
+ provides = pandoc-panflute
+ conflicts = pandoc-panflute
source = python-panflute-1.12.4.tar.gz::https://github.com/sergiocorreia/panflute/archive/1.12.4.tar.gz
sha256sums = 92f9f712a54151b07af736b3b6ba1733c3602600c84b4407fdb714272ff92565
diff --git a/PKGBUILD b/PKGBUILD
index 6fbebc089894..f8cee59ef9cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,30 @@
# PKGBUILD generated by pipman
# Python package author: Sergio Correia <sergio.correia@gmail.com>
-_name=panflute
-pkgname=python-$_name
+_pipname=panflute
+pkgname=python-$_pipname
pkgver=1.12.4
-pkgrel=1
-pkgdesc="Pythonic Pandoc filters"
-arch=(any)
-url="https://github.com/sergiocorreia/$_name"
-license=(BSD3)
-makedepends=("python" "python-pip")
-depends=("python-click"
- "python-yaml"
- "python-shutilwhich")
-source=("$pkgname-$pkgver.tar.gz::https://github.com/sergiocorreia/$_name/archive/$pkgver.tar.gz")
+pkgrel=2
+pkgdesc='A Pythonic alternative to John MacFarlane’s pandocfilters'
+arch=('any')
+url="https://github.com/sergiocorreia/$_pipname"
+license=('BSD')
+makedepends=('python-pip')
+depends=('python'
+ 'python-click'
+ 'python-yaml'
+ 'python-shutilwhich')
+provides=('pandoc-panflute')
+conflicts=('pandoc-panflute')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/sergiocorreia/$_pipname/archive/$pkgver.tar.gz")
sha256sums=('92f9f712a54151b07af736b3b6ba1733c3602600c84b4407fdb714272ff92565')
build() {
- cd "$srcdir/$_name-$pkgver"
+ cd "$_name-$pkgver"
python setup.py build
}
package() {
- cd "$srcdir/$_name-$pkgver"
+ cd "$_name-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
}