summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD23
3 files changed, 14 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af4ebcd91000..efa232913166 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = python-parsita
pkgdesc = Parser combinator library for Python.
- pkgver = 1.6.1
+ pkgver = 1.7.0
pkgrel = 1
url = https://pypi.org/project/parsita
arch = any
license = MIT
makedepends = python-setuptools
depends = python
- source = python-parsita-1.6.1.tar.gz::https://pypi.org/packages/source/p/parsita/parsita-1.6.1.tar.gz
- source = LICENSE
- sha256sums = 6dae2b02cb172f41811419ef9600e6f81bc90378a82526595b94d8770dc92955
- sha256sums = 0d9510b6afe453291bc7fecc863b17d15d9b7931c5c55e22b55b93ba6195ff70
- b2sums = d2aa2e4baef1d9436e22bf40585710263917e7c320fb2c92276c7533c5f61c624c1f65b5b78b72c278abd2456b7847e8c0e5e229f812d309c93a6866c66c10bf
- b2sums = b058113fdc8cbeaf79c8adbc5df46b92cd7d415d8793ccf52fb98fa2bcc668630164134ae05c0a5ac2ed4c8acf51fc7d43c2e6ec77282dc9058a1fae3819e957
+ source = python-parsita-1.7.0.tar.gz::https://github.com/drhagen/parsita/archive/refs/tags/v1.7.0.tar.gz
+ sha256sums = 080f72c24250d2efbca2a10a388fb9ae6d040ef7bdf62cbd448fd39540ec55a0
+ b2sums = 04851b52cb8386e633c5bde2c603a45dc444c84de3955b2086253b0a06f0a75c0ffcb2a7cd34c4a665686adf543a0b158c53267ac66bf8bc687654f79179aa51
pkgname = python-parsita
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 174233e9c60f..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,20 +0,0 @@
-The MIT License (MIT)
-
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the “Software”), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 90d47662fc75..a556314cc0b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,34 @@
_pkgname=parsita
pkgname="python-${_pkgname}"
-pkgver=1.6.1
+pkgver=1.7.0
pkgrel=1
pkgdesc="Parser combinator library for Python."
arch=('any')
-url="https://pypi.org/project/${_pkgname}"
+url="https://pypi.org/project/parsita"
license=('MIT')
depends=('python')
makedepends=('python-setuptools')
-source=("${pkgname}-${pkgver}.tar.gz::https://pypi.org/packages/source/${_pkgname:0:1}/${_pkgname/-/_}/${_pkgname/-/_}-${pkgver}.tar.gz"
- LICENSE)
-sha256sums=('6dae2b02cb172f41811419ef9600e6f81bc90378a82526595b94d8770dc92955'
- '0d9510b6afe453291bc7fecc863b17d15d9b7931c5c55e22b55b93ba6195ff70')
-b2sums=('d2aa2e4baef1d9436e22bf40585710263917e7c320fb2c92276c7533c5f61c624c1f65b5b78b72c278abd2456b7847e8c0e5e229f812d309c93a6866c66c10bf'
- 'b058113fdc8cbeaf79c8adbc5df46b92cd7d415d8793ccf52fb98fa2bcc668630164134ae05c0a5ac2ed4c8acf51fc7d43c2e6ec77282dc9058a1fae3819e957')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/drhagen/parsita/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('080f72c24250d2efbca2a10a388fb9ae6d040ef7bdf62cbd448fd39540ec55a0')
+b2sums=('04851b52cb8386e633c5bde2c603a45dc444c84de3955b2086253b0a06f0a75c0ffcb2a7cd34c4a665686adf543a0b158c53267ac66bf8bc687654f79179aa51')
build() {
- cd "${_pkgname/-/_}-${pkgver}"
+ cd "$_pkgname-$pkgver"
python setup.py build
}
check() {
- cd "${_pkgname/-/_}-${pkgver}"
+ cd "$_pkgname-$pkgver"
export PYTHONPATH="build/lib"
python setup.py test
}
package() {
- cd "${_pkgname/-/_}-${pkgver}"
+ cd "$_pkgname-$pkgver"
- python setup.py install --root="${pkgdir}" --optimize=1
- install -Dm0644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}