summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD38
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b210608d31f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-parsita
+ pkgdesc = Parser combinator library for Python.
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://pypi.org/project/parsita
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = python-parsita-1.4.0.tar.gz::https://pypi.org/packages/source/p/parsita/parsita-1.4.0.tar.gz
+ source = LICENSE
+ sha256sums = 084707eb2459f2ad9baf03c0408789362f63b52e3797431c10c7b99c1a43095f
+ sha256sums = 0d9510b6afe453291bc7fecc863b17d15d9b7931c5c55e22b55b93ba6195ff70
+ b2sums = 7968e65806a8d44ce0739ddf8a303ffa728f61445f6fec12c486f35b7363b21d6bd0a09443f3ff993dabb3c5f6b8cbaef771cf3d4d7802ab94225dd191125a96
+ b2sums = b058113fdc8cbeaf79c8adbc5df46b92cd7d415d8793ccf52fb98fa2bcc668630164134ae05c0a5ac2ed4c8acf51fc7d43c2e6ec77282dc9058a1fae3819e957
+
+pkgname = python-parsita
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..174233e9c60f
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+The MIT License (MIT)
+
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the “Software”), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ea4592ee40d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: KokaKiwi <kokakiwi+aur@kokakiwi.net>
+
+_pkgname=parsita
+pkgname="python-${_pkgname}"
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Parser combinator library for Python."
+arch=('any')
+url="https://pypi.org/project/${_pkgname}"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://pypi.org/packages/source/${_pkgname:0:1}/${_pkgname/-/_}/${_pkgname/-/_}-${pkgver}.tar.gz"
+ LICENSE)
+sha256sums=('084707eb2459f2ad9baf03c0408789362f63b52e3797431c10c7b99c1a43095f'
+ '0d9510b6afe453291bc7fecc863b17d15d9b7931c5c55e22b55b93ba6195ff70')
+b2sums=('7968e65806a8d44ce0739ddf8a303ffa728f61445f6fec12c486f35b7363b21d6bd0a09443f3ff993dabb3c5f6b8cbaef771cf3d4d7802ab94225dd191125a96'
+ 'b058113fdc8cbeaf79c8adbc5df46b92cd7d415d8793ccf52fb98fa2bcc668630164134ae05c0a5ac2ed4c8acf51fc7d43c2e6ec77282dc9058a1fae3819e957')
+
+build() {
+ cd "${_pkgname/-/_}-${pkgver}"
+
+ python setup.py build
+}
+
+check() {
+ cd "${_pkgname/-/_}-${pkgver}"
+
+ export PYTHONPATH="build/lib"
+ python setup.py test
+}
+
+package() {
+ cd "${_pkgname/-/_}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm0644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}