summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 24 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45a7ce8a2c17..1db5d68a7e43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = python-pdb2pqr
pkgdesc = Automates many of the common tasks of preparing structures for continuum solvation calculations as well as many other types of biomolecular structure modeling, analysis, and simulation.
- pkgver = 3.1.0
+ pkgver = 3.6.2
pkgrel = 1
url = http://pypi.python.org/pypi/pdb2pqr
arch = any
license = BSD
+ checkdepends = python-pandas>=1.0
+ checkdepends = python-pytest
+ checkdepends = python-testfixtures
depends = python>=3.5
- depends = python-propka>=3.2
- depends = python-pandas>=1.0
- depends = python-pytest>=5.4.1
+ depends = python-mmcif-pdbx>=1.1.2
+ depends = python-numpy
+ depends = python-propka>=3.5
+ depends = python-requests
+ depends = python-docutils
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/p/pdb2pqr/pdb2pqr-3.1.0.tar.gz
- sha256sums = a6f5e2eefbd8bd2a072a89ee4026977de02dadd56e921095afac88d596b63820
+ source = https://files.pythonhosted.org/packages/source/p/pdb2pqr/pdb2pqr-3.6.2.tar.gz
+ sha256sums = SKIP
pkgname = python-pdb2pqr
-
diff --git a/PKGBUILD b/PKGBUILD
index 4802c3024617..85b2a00610c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,29 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Kherim Willems <aur@kher.im>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
pkgname=python-pdb2pqr
_name=${pkgname#python-}
-pkgver=3.1.0
+pkgver=3.6.2
pkgrel=1
pkgdesc="Automates many of the common tasks of preparing structures for continuum solvation calculations as well as many other types of biomolecular structure modeling, analysis, and simulation."
arch=(any)
url="http://pypi.python.org/pypi/${_name}"
license=(BSD)
-depends=('python>=3.5' 'python-propka>=3.2' 'python-pandas>=1.0' 'python-pytest>=5.4.1')
+depends=('python>=3.5' 'python-mmcif-pdbx>=1.1.2' python-numpy
+ 'python-propka>=3.5' python-requests python-docutils)
+checkdepends=('python-pandas>=1.0' python-pytest python-testfixtures)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('a6f5e2eefbd8bd2a072a89ee4026977de02dadd56e921095afac88d596b63820')
+sha256sums=('SKIP')
options=(!emptydirs)
build() {
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py build
+ cd "${srcdir}/${_name}-${pkgver}"
+
+ python setup.py build
}
package() {
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
-}
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}