summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD23
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e770f83babd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-peeweeplus
+ pkgdesc = Practical extension of a small, expressive ORM
+ pkgver = 1.4.9
+ pkgrel = 1
+ url = https://gitlab.com/HOMEINFO/peeweeplus
+ arch = any
+ license = GPLv3
+ makedepends = git
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python-setuptools-git
+ depends = python
+ depends = python-peewee
+ depends = python-timelib
+ depends = python-strflib
+ optdepends = python-argon2_cffi: for Argon2Field
+ optdepends = python-authlib: for authlib integration
+ provides = python-peeweeplus
+ conflicts = python-peeweeplus
+ source = peeweeplus::git+https://gitlab.com/HOMEINFO/peeweeplus.git#tag=1.4.9
+ md5sums = SKIP
+
+pkgname = python-peeweeplus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94af5b5eb9d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Richard Neumann aka. schard <mail at richard dash neumann period de>
+
+_pkgbase='peeweeplus'
+pkgname="python-${_pkgbase}"
+pkgver=1.4.9
+pkgrel=1
+pkgdesc='Practical extension of a small, expressive ORM'
+arch=('any')
+url="https://gitlab.com/HOMEINFO/${_pkgbase}"
+license=('GPLv3')
+depends=('python' 'python-peewee' 'python-timelib' 'python-strflib')
+optdepends=('python-argon2_cffi: for Argon2Field' 'python-authlib: for authlib integration')
+makedepends=('git' 'python' 'python-setuptools' 'python-setuptools-git')
+provides=("python-${_pkgbase}")
+conflicts=("python-${_pkgbase}")
+source=("${_pkgbase}::git+${url}.git#tag=${pkgver}")
+md5sums=('SKIP')
+
+
+package() {
+ cd "${_pkgbase}"
+ python setup.py install --root "${pkgdir}" --optimize=1
+}