summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bda3f1950199
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-peeweeplus-git
+ pkgdesc = Practical extension of a small, expressive ORM
+ pkgver = latest
+ pkgrel = 1
+ url = https://gitlab.com/HOMEINFO/peeweeplus
+ arch = any
+ license = GPLv3
+ makedepends = git
+ makedepends = python
+ depends = python
+ depends = python-peewee
+ depends = python-argon2_cffi
+ depends = python-timelib-git
+ source = peeweeplus::git+https://gitlab.com/HOMEINFO/peeweeplus.git
+ md5sums = SKIP
+
+pkgname = python-peeweeplus-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82cb20c6c43a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.tar.xz*
+peeweeplus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..79769684f71d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Richard Neumann aka. schard <mail at richard dash neumann period de>
+
+_pkgbase='peeweeplus'
+pkgname="python-${_pkgbase}-git"
+pkgver=latest
+pkgrel=1
+pkgdesc='Practical extension of a small, expressive ORM'
+arch=('any')
+url="https://gitlab.com/HOMEINFO/${_pkgbase}"
+license=('GPLv3')
+depends=('python' 'python-peewee' 'python-argon2_cffi' 'python-timelib-git')
+makedepends=('git' 'python')
+source=("${_pkgbase}::git+${url}.git")
+md5sums=('SKIP')
+pkgdir='pkg'
+srcdir='src'
+
+
+pkgver() {
+ cd "${_pkgbase}" || exit 1
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "${srcdir}/${_pkgbase}"
+ python setup.py install --root "${pkgdir}" --optimize=1
+}