summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--CHANGES.rst12
-rw-r--r--PKGBUILD9
3 files changed, 21 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62f0001a5548..6162e6edfa9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pex
- pkgdesc = a tool for generating executable Python environments
- pkgver = 2.1.51
+ pkgdesc = Generates executable Python environments
+ pkgver = 2.1.52
pkgrel = 1
url = https://github.com/pantsbuild/pex
changelog = CHANGES.rst
@@ -9,8 +9,9 @@ pkgbase = python-pex
makedepends = git
makedepends = python-setuptools
makedepends = python-dephell
+ makedepends = python-sphinx
depends = python
- source = python-pex::git+https://github.com/pantsbuild/pex#tag=v2.1.51?signed
+ source = python-pex::git+https://github.com/pantsbuild/pex#tag=v2.1.52?signed
validpgpkeys = A1FE765B15233EAD18FA6ABB93E55CB567B5C626
sha256sums = SKIP
diff --git a/CHANGES.rst b/CHANGES.rst
index 07f84eada33a..e3cb3fcdffd7 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,6 +1,16 @@
Release Notes
=============
+2.1.52
+------
+
+This release makes a wider array of distributions resolvable for
+``--platform`` resolves by inferring the ``platform_machine``
+environment marker corresponding to the requested ``--platform``.
+
+* Populate ``platform_machine`` in ``--platform`` resolve. (#1489)
+ `PR #1489 <https://github.com/pantsbuild/pex/pull/1489>`_
+
2.1.51
------
@@ -9,7 +19,7 @@ distributions that contain scripts with non-ascii characters in them
when running in environments with a default encoding that does not
contain those characters under PyPy3, Python 3.5 and Python 3.6.
-* Fix non-ascii script shebang re-writing. (#1480)
+* Fix non-ascii script shebang re-writing. (#1480)
`PR #1480 <https://github.com/pantsbuild/pex/pull/1480>`_
2.1.50
diff --git a/PKGBUILD b/PKGBUILD
index 2ea989877845..a1bf0f37f4be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
# Contributor: Carlo Cabanilla <carlo.cabanilla@gmail.com>
pkgname=python-pex
-pkgver=2.1.51
+pkgver=2.1.52
pkgrel=1
arch=('any')
-pkgdesc='a tool for generating executable Python environments'
+pkgdesc='Generates executable Python environments'
url='https://github.com/pantsbuild/pex'
license=('Apache')
depends=('python')
-makedepends=('git' 'python-setuptools' 'python-dephell')
+makedepends=('git' 'python-setuptools' 'python-dephell' 'python-sphinx')
# checkdepends=('python-pytest-runner' 'python-pkginfo')
changelog=CHANGES.rst
source=("$pkgname::git+$url#tag=v$pkgver?signed")
@@ -26,6 +26,8 @@ prepare() {
build() {
cd "$pkgname"
python setup.py build
+ cd docs
+ make man
}
## 25 minutes to run a test suite lol no thanks
@@ -38,4 +40,5 @@ build() {
package() {
cd "$pkgname"
PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm 644 docs/_build/man/pex.1 -t "$pkgdir/usr/share/man/man1/"
}