summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGES.rst39
-rw-r--r--PKGBUILD10
3 files changed, 48 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 556c41ecdf5c..95e00e363a0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pex
pkgdesc = Generates executable Python environments
- pkgver = 2.1.104
+ pkgver = 2.1.107
pkgrel = 1
url = https://github.com/pantsbuild/pex
changelog = CHANGES.rst
@@ -14,7 +14,7 @@ pkgbase = python-pex
depends = python
provides = pex
replaces = pex
- source = python-pex::git+https://github.com/pantsbuild/pex#tag=v2.1.104?signed
+ source = python-pex::git+https://github.com/pantsbuild/pex#tag=v2.1.107?signed
validpgpkeys = A1FE765B15233EAD18FA6ABB93E55CB567B5C626
sha256sums = SKIP
diff --git a/CHANGES.rst b/CHANGES.rst
index 729710479169..be93a0e4d509 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,6 +1,45 @@
Release Notes
=============
+2.1.107
+-------
+
+This release fixes an issue handling credentials in git+ssh VCS urls
+when creating locks.
+
+* Fix locks for git+ssh with credentials. (#1923)
+ `PR #1923 <https://github.com/pantsbuild/pex/pull/1923>`_
+
+2.1.106
+-------
+
+This release fixes a long standing bug in handling direct reference
+requirements with a local version component.
+
+* Unquote path component of parsed url requirements (#1920)
+ `PR #1920 <https://github.com/pantsbuild/pex/pull/1920>`_
+
+2.1.105
+-------
+
+This is a fix release which addresses issues related to build time
+work_dir creation, virtualenv, and sh_boot support.
+
+In the unlikely event of a UUID collision in atomic workdir creation,
+pex could overwrite an existing directory and cause a corrupt state.
+When building a shell bootable ``--sh-boot`` pex the
+``--runtime-pex-root`` was not always respected based on the condition
+of the build environment, and the value of the PEX_ROOT.
+
+* Fail on atomic_directory work_dir collision. (#1905)
+ `PR #1905 <https://github.com/pantsbuild/pex/pull/1905>`_
+
+* Use raw_pex_root when constructing sh_boot pexes. (#1906)
+ `PR #1906 <https://github.com/pantsbuild/pex/pull/1906>`_
+
+* Add support for offline downloads (#1898)
+ `PR #1898 <https://github.com/pantsbuild/pex/pull/1898>`_
+
2.1.104
-------
diff --git a/PKGBUILD b/PKGBUILD
index f4e4985f72f0..49452a9fc65d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
## GPG key: https://github.com/jsirois.gpg
pkgname=python-pex
-pkgver=2.1.104
+pkgver=2.1.107
pkgrel=1
arch=('any')
pkgdesc='Generates executable Python environments'
@@ -22,10 +22,14 @@ source=("$pkgname::git+$url#tag=v$pkgver?signed")
sha256sums=('SKIP')
validpgpkeys=('A1FE765B15233EAD18FA6ABB93E55CB567B5C626')
+prepare() {
+ cd "$pkgname"
+ sed -i '2c\requires = ["flit_core>=2"]' pyproject.toml
+}
+
build() {
cd "$pkgname"
- ## requires python-flit-core>=2,<3
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
make -C docs man
}