summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGES.rst14
-rw-r--r--PKGBUILD2
-rwxr-xr-xget-changelog.sh7
4 files changed, 24 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6162e6edfa9d..d79e2ae7af32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pex
pkgdesc = Generates executable Python environments
- pkgver = 2.1.52
+ pkgver = 2.1.53
pkgrel = 1
url = https://github.com/pantsbuild/pex
changelog = CHANGES.rst
@@ -11,7 +11,7 @@ pkgbase = python-pex
makedepends = python-dephell
makedepends = python-sphinx
depends = python
- source = python-pex::git+https://github.com/pantsbuild/pex#tag=v2.1.52?signed
+ source = python-pex::git+https://github.com/pantsbuild/pex#tag=v2.1.53?signed
validpgpkeys = A1FE765B15233EAD18FA6ABB93E55CB567B5C626
sha256sums = SKIP
diff --git a/CHANGES.rst b/CHANGES.rst
index e3cb3fcdffd7..72ae8ff25b39 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,6 +1,20 @@
Release Notes
=============
+2.1.53
+------
+
+This release fixes a bug identifying certain interpreters on macOS
+Monterey. Additionally, Pex now exposes the ``PEX`` environment
+variable inside running PEXes to allow application code to both detect
+it's running from a PEX and determine where that PEX is located.
+
+* Guard against fake interpreters. (#1500)
+ `PR #1500 <https://github.com/pantsbuild/pex/pull/1500>`_
+
+* Introduce the ``PEX`` env var. (#1495)
+ `PR #1495 <https://github.com/pantsbuild/pex/pull/1495>`_
+
2.1.52
------
diff --git a/PKGBUILD b/PKGBUILD
index a1bf0f37f4be..4c88c8fda881 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Carlo Cabanilla <carlo.cabanilla@gmail.com>
pkgname=python-pex
-pkgver=2.1.52
+pkgver=2.1.53
pkgrel=1
arch=('any')
pkgdesc='Generates executable Python environments'
diff --git a/get-changelog.sh b/get-changelog.sh
new file mode 100755
index 000000000000..9fe0873f72d4
--- /dev/null
+++ b/get-changelog.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+if [ -z "$1" ]; then
+ echo 'usage: ./get-changelog.sh "<version>"'
+else
+ curl -O "https://raw.githubusercontent.com/pantsbuild/pex/v$1/CHANGES.rst"
+fi