summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD26
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a08b94cd17d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Dec 10 05:28:29 UTC 2015
+pkgbase = python-pickups-git
+ pkgdesc = IRC gateway for Google Hangouts
+ pkgver = 36.b25967e
+ pkgrel = 1
+ url = https://github.com/mtomwing/pickups
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = hangups-git
+ source = git+https://github.com/mtomwing/pickups.git
+ sha256sums = SKIP
+
+pkgname = python-pickups-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a3d1a4c8d3a1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pickups/
+python-pickups-git-*-package.log
+python-pickups-git-*-pkgver.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86f035f797e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Yardena Cohen <yardenack at gmail dot com>
+
+gitname=pickups
+pkgname=python-${gitname}-git
+pkgver=36.b25967e
+pkgrel=1
+pkgdesc='IRC gateway for Google Hangouts'
+arch=('any')
+license=('MIT')
+url="https://github.com/mtomwing/${gitname}"
+depends=('python' 'hangups-git')
+makedepends=('python-setuptools')
+source=("git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${gitname}"
+ local ver="$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ printf "%s" "${ver//-/.}"
+}
+
+
+package() {
+ mkdir -p "${pkgdir}//usr/lib/python3.5/site-packages"
+ cp -a "${srcdir}/${gitname}/${gitname}" "${pkgdir}//usr/lib/python3.5/site-packages/${gitname}"
+}