summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 18 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a76fe43ae0de..6a153ca6984f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-picos-git
pkgdesc = A Python interface to conic optimization solvers. Git version.
- pkgver = 2.0.r8.g7c304b3
+ pkgver = 2.0.r12.g11f96c1
pkgrel = 1
url = https://gitlab.com/picos-api/picos
arch = any
@@ -9,6 +9,13 @@ pkgbase = python-picos-git
makedepends = python-setuptools
depends = python-numpy
depends = python-cvxopt
+ optdepends = cplex: solve using CPLEX
+ optdepends = gurobi: solve using Gurobi
+ optdepends = mosek: solve using MOSEK
+ optdepends = python-ecos: solve using ECOS
+ optdepends = python-pyscipopt: solve using SCIP
+ optdepends = python-smcp: solve using SMCP
+ optdepends = python-swiglpk: solve using GLPK
conflicts = python-picos
source = picos::git+https://gitlab.com/picos-api/picos.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d303cd7dccab..35e73d1b7ee5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,22 @@
# Maintainer: Maximilian Stahlberg <maximilian.stahlberg tu-berlin de>
pkgname=python-picos-git
-pkgver=2.0.r8.g7c304b3
+pkgver=2.0.r12.g11f96c1
pkgrel=1
pkgdesc='A Python interface to conic optimization solvers. Git version.'
arch=('any')
url='https://gitlab.com/picos-api/picos'
license=('GPL3')
depends=('python-numpy' 'python-cvxopt')
+optdepends=(
+ 'cplex: solve using CPLEX'
+ 'gurobi: solve using Gurobi'
+ 'mosek: solve using MOSEK'
+ 'python-ecos: solve using ECOS'
+ 'python-pyscipopt: solve using SCIP'
+ 'python-smcp: solve using SMCP'
+ 'python-swiglpk: solve using GLPK'
+)
makedepends=('git' 'python-setuptools')
conflicts=('python-picos')
source=("picos::git+https://gitlab.com/picos-api/picos.git")