summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2d60215ecc1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = python-plotly_express
+ pkgdesc = Plotly Express: a high level wrapper for Plotly.py
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/plotly/plotly_express
+ arch = any
+ license = UNKNOWN
+ makedepends = python
+ makedepends = python-pip
+
+pkgname = python-plotly_express
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46fa4b000fcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# PKGBUILD generated by pipman
+# Python package author: Nicolas Kruchten <nicolas@plot.ly>
+pkgname=python-plotly_express
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Plotly Express: a high level wrapper for Plotly.py"
+arch=(any)
+url="https://github.com/plotly/plotly_express"
+license=(UNKNOWN)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="plotly_express" plotly_express==0.1.1
+}
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ mkdir -p $pkgdir/"$sitepackages"
+ cp -r $srcdir/plotly_express/* $pkgdir/"$sitepackages"
+} \ No newline at end of file