summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 6 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba5dd5d9aeb9..d22f25daea8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,14 @@
pkgbase = python-pluginbase
pkgdesc = A support library for building plugins systems in Python.
pkgver = 1.0.0
- pkgrel = 3
+ pkgrel = 4
url = http://pluginbase.pocoo.org/
arch = any
license = BSD
makedepends = python-setuptools
- makedepends = python2-setuptools
- makedepends = fakeroot
+ depends = python
source = https://github.com/mitsuhiko/pluginbase/archive/1.0.0.tar.gz
sha256sums = ab0e5fc405f1d28abe99724943ad54b5e7fb1c2f6b1519f0942e2074e6c8c22a
pkgname = python-pluginbase
- depends = python
-
-pkgname = python2-pluginbase
- depends = python2
diff --git a/PKGBUILD b/PKGBUILD
index 852956544a17..620e8a2acb43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,33 +4,25 @@
_name="pluginbase"
_module="$_name"
-pkgname=("python-$_module" "python2-$_module")
+pkgname=("python-$_module")
pkgver=1.0.0
-pkgrel=3
+pkgrel=4
pkgdesc="A support library for building plugins systems in Python."
arch=("any")
url="http://pluginbase.pocoo.org/"
license=("BSD")
-makedepends=("python-setuptools" "python2-setuptools" "fakeroot")
+makedepends=("python-setuptools")
+depends=("python")
source=("https://github.com/mitsuhiko/pluginbase/archive/$pkgver.tar.gz")
sha256sums=('ab0e5fc405f1d28abe99724943ad54b5e7fb1c2f6b1519f0942e2074e6c8c22a')
build() {
cd "$_name-$pkgver"
python setup.py build
- python2 setup.py build
}
package_python-pluginbase() {
- depends=("python")
cd "$_name-$pkgver"
python setup.py install --skip-build --root="$pkgdir" --optimize=1
install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}
-
-package_python2-pluginbase() {
- depends=("python2")
- cd "$_name-$pkgver"
- python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
- install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
-}