summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b0f6f360f30..956d61461ead 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = python-plum
pkgdesc = Pack/Unpack Memory
- pkgver = 0.7.2
+ pkgver = 0.7.9
pkgrel = 1
url = https://plum-py.readthedocs.io/en/latest/
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
- source = https://gitlab.com/dangass/plum/-/archive/0.7.2/plum-0.7.2.tar.bz2
- sha256sums = 6b2863af4db754892d690563b8304b43c246e8d3a1124ad8aeab83f2fc86ffbc
+ source = https://gitlab.com/dangass/plum/-/archive/0.7.9/plum-0.7.9.tar.bz2
+ sha256sums = 0f660a767ceb7a0374066ab3077fc274c409e751a00a904ddfe6ec88b52549a9
pkgname = python-plum
diff --git a/PKGBUILD b/PKGBUILD
index acc130b3c559..dd8150ee9d36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
-_pipname=plum
-pkgname=python-${_pipname,,}
-pkgver=0.7.2
+_pyname=plum
+pkgname=python-${_pyname,,}
+pkgver=0.7.9
pkgrel=1
pkgdesc='Pack/Unpack Memory'
arch=(any)
-url="https://$_pipname-py.readthedocs.io/en/latest/"
+url="https://$_pyname-py.readthedocs.io/en/latest/"
license=(MIT)
depends=(python)
-makedepends=(python-setuptools)
-_archive="$_pipname-$pkgver"
-source=("https://gitlab.com/dangass/$_pipname/-/archive/$pkgver/$_archive.tar.bz2")
-sha256sums=('6b2863af4db754892d690563b8304b43c246e8d3a1124ad8aeab83f2fc86ffbc')
+makedepends=(python-{build,installer}
+ python-setuptools
+ python-wheel)
+_archive="$_pyname-$pkgver"
+source=("https://gitlab.com/dangass/$_pyname/-/archive/$pkgver/$_archive.tar.bz2")
+sha256sums=('0f660a767ceb7a0374066ab3077fc274c409e751a00a904ddfe6ec88b52549a9')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}