summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4dfa22c0f89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Jul 9 23:25:35 UTC 2016
+pkgbase = python-pocketsphinx-git
+ pkgdesc = Python interface to CMU SphinxBase and PocketSphinx libraries
+ pkgver = r68.24ab446
+ pkgrel = 1
+ url = https://github.com/bambocher/pocketsphinx-python
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = python
+ depends = swig
+ source = python-pocketsphinx::git+https://github.com/cmusphinx/pocketsphinx-python.git
+ sha256sums = SKIP
+
+pkgname = python-pocketsphinx-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21523301c177
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=python-pocketsphinx-git
+pkgver=r68.24ab446
+pkgrel=1
+pkgdesc='Python interface to CMU SphinxBase and PocketSphinx libraries'
+arch=('i686' 'x86_64')
+url='https://github.com/bambocher/pocketsphinx-python'
+license=('BSD')
+depends=('python' 'swig')
+makedepends=('git')
+source=('python-pocketsphinx::git+https://github.com/cmusphinx/pocketsphinx-python.git')
+sha256sums=('SKIP')
+_gitname='python-pocketsphinx'
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${_gitname}"
+
+ # Should I do a status before init?
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+
+ python setup.py build
+}
+package() {
+ cd "${srcdir}/${_gitname}"
+
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}
+
+# vim: set ts=2 sw=2 ft=sh noet: