summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c6819cec659..1b4052d20169 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-poetry-core-git
- pkgdesc = Poetry PEP 517 Build Backend & Core Utilities
- pkgver = 1.2.0b3.r16.gec610a34
+ pkgdesc = Poetry PEP 517 Build Backend
+ pkgver = 1.8.1.r17.g21b0033
pkgrel = 1
url = https://github.com/python-poetry/poetry-core
arch = any
@@ -8,10 +8,9 @@ pkgbase = python-poetry-core-git
makedepends = python-build
makedepends = python-installer
makedepends = git
- depends = python-jsonschema
+ depends = python-fastjsonschema
depends = python-lark-parser
depends = python-packaging
- depends = python-tomlkit
provides = poetry-core
provides = python-poetry-core
conflicts = poetry-core
diff --git a/PKGBUILD b/PKGBUILD
index d6e8c1187e06..91a3f3ca8b0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Contributor: Thiago França<tfsthiagobr98@outlook.com>
_pkgname=poetry-core
pkgname=python-${_pkgname}-git
-pkgver=1.2.0b3.r16.gec610a34
+pkgver=1.8.1.r17.g21b0033
pkgrel=1
-pkgdesc="Poetry PEP 517 Build Backend & Core Utilities"
-arch=('any')
+pkgdesc="Poetry PEP 517 Build Backend"
+arch=(any)
url="https://github.com/python-poetry/${_pkgname}"
license=('MIT')
-_deps=('jsonschema' 'lark-parser' 'packaging' 'tomlkit')
+_deps=(fastjsonschema lark-parser packaging)
depends=("${_deps[@]/#/python-}")
makedepends=(python-{build,installer} git)
# checkdepends=(python-pytest python-pytest-mock python-virtualenv)