summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7970a02ca3d2..5fc34ce7d84f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,8 @@ pkgbase = python-polyline
url = https://github.com/hicsail/polyline
arch = any
license = MIT
+ makedepends = python2-setuptools
+ makedepends = python-setuptools
source = https://github.com/hicsail/polyline/archive/v1.3.tar.gz
md5sums = b153232f7b2ac11c9976c54fcc93aaf5
diff --git a/PKGBUILD b/PKGBUILD
index 85da5830530b..35b7adfc20d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,8 @@ pkgdesc="A Python implementation of Google's Encoded Polyline Algorithm Format."
arch=("any")
url="https://github.com/hicsail/polyline"
license=('MIT')
+makedepends=("python2-setuptools" "python-setuptools")
source=("https://github.com/hicsail/polyline/archive/v$pkgver.tar.gz")
-build() {
- cd "$srcdir/polyline-$pkgver"
- ls -al
- python2 setup.py build
-}
package_python-polyline() {
depends=("python")