summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bbdfc5480bdd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pqdict
+ pkgdesc = A Pythonic indexed priority queue
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/nvictus/priority-queue-dictionary
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ source = https://github.com/nvictus/priority-queue-dictionary/archive/v1.0.tar.gz
+ sha256sums = 811f3912a7ffe36d37b973f57eb0ef9c5abcf0407d22325a2bed0653e1a5766c
+
+pkgname = python-pqdict
+ depends = python
+ depends = kafka
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fdd9f1c8b90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jerry Lin <jerry73204 at gmail dot com>
+
+pkgname='python-pqdict'
+pkgver=1.0
+pkgrel=1
+pkgdesc='A Pythonic indexed priority queue'
+arch=('x86_64')
+url="https://github.com/nvictus/priority-queue-dictionary"
+license=('MIT')
+makedepends=('python-setuptools')
+source=("https://github.com/nvictus/priority-queue-dictionary/archive/v${pkgver}.tar.gz")
+sha256sums=('811f3912a7ffe36d37b973f57eb0ef9c5abcf0407d22325a2bed0653e1a5766c')
+
+_dirname="priority-queue-dictionary-${pkgver}"
+
+build() {
+ cd "${srcdir}/${_dirname}"
+ python setup.py build
+}
+
+package() {
+ depends=('python' 'kafka')
+ cd "${srcdir}/${_dirname}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}