summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD28
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd41ed204d6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-prospector
+ pkgdesc = Python static analysis tool
+ pkgver = 0.12
+ pkgrel = 1
+ url = https://github.com/landscapeio/prospector
+ arch = any
+ license = GPL2
+ makedepends = python-setuptools
+ makedepends = pydocstyle
+ makedepends = python-pep8-naming
+ makedepends = python-yaml
+ makedepends = python-dodgy
+ makedepends = python-setoptconf
+ makedepends = python-requirements-detector
+ makedepends = python-pylint-common
+ makedepends = python-pylint-plugin-utils
+ makedepends = python-pylint-django
+ makedepends = python-pylint-celery
+ makedepends = python-pylint-flask
+ source = https://github.com/landscapeio/prospector/archive/0.12.tar.gz
+ md5sums = 45d00e6b6b70b69d3f02c64c74f9f40c
+
+pkgname = python-prospector
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df981bfc9b30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+
+pkgname=python-prospector
+pkgver=0.12
+pkgrel=1
+pkgdesc="Python static analysis tool"
+arch=('any')
+makedepends=('python-setuptools' 'pydocstyle' 'python-pep8-naming' 'python-yaml' 'python-dodgy' 'python-setoptconf'
+ 'python-requirements-detector' 'python-pylint-common' 'python-pylint-plugin-utils'
+ 'python-pylint-django' 'python-pylint-celery' 'python-pylint-flask')
+url="https://github.com/landscapeio/prospector"
+license=('GPL2')
+source=(https://github.com/landscapeio/prospector/archive/${pkgver}.tar.gz)
+md5sums=('45d00e6b6b70b69d3f02c64c74f9f40c')
+
+build() {
+ cd "$srcdir/${pkgname#python-}-$pkgver"
+
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname#python-}-$pkgver"
+
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm755 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"/LICENSE
+}
+# vim:set ts=2 sw=2 et: