summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--Makefile23
-rw-r--r--PKGBUILD11
-rw-r--r--Relative-paths-should-be-allowed.patch84
5 files changed, 122 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45f69e73eca1..4e67293d4df7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pssh
pkgdesc = Parallel versions of the openssh tools ssh, scp, rsync, nuke, slurp
pkgver = 2.3.1
- pkgrel = 9
+ pkgrel = 10
url = http://code.google.com/p/parallel-ssh/
changelog = python-pssh.changelog
arch = any
@@ -14,11 +14,13 @@ pkgbase = python-pssh
source = pssh-typeerror-str-does-not-support-the-buffer-interface.patch
source = pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
source = pssh-read-stdin-as-bytes-in-Python-3.patch
+ source = Relative-paths-should-be-allowed.patch
sha256sums = 539f8d8363b722712310f3296f189d1ae8c690898eca93627fc89a9cb311f6b4
sha256sums = 12257c60e7db3d152f0b3307d0cd0263a95bddfc856aa570908a0491a1a03c56
sha256sums = 6b4574810b09f4ca855b81a036643aa27613ea69e1cd92755b9b9f155985d332
sha256sums = 40b01fd5c2aa59542a5d1bf65a41b861733f71305a9799c1d1ca6661f228a891
sha256sums = 47c1af738d4ba252e9f35c5633da91bae2a2919a7b6b2bf425ee1f090d61c7fe
+ sha256sums = 3ba2ec624ac2aa3dbd832311ade97b65ab389b4b4aa55a4b672447809c7b463a
pkgname = python-pssh
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6dd39bbd03b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar
+*.[gx]z
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..d98ad5acca65
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,23 @@
+nam = $(shell sed -n 's/^pkgname=//p' PKGBUILD)
+src = PKGBUILD
+inf = .SRCINFO
+pkg = $(shell ls -v $(nam)*.pkg.tar* 2>/dev/null | tail -1)
+
+all: sum $(inf) check
+
+$(inf): $(src)
+ makepkg --printsrcinfo >$@
+
+check: $(src)
+ namcap $^
+ifneq ($(strip $(pkg)),)
+ namcap $(pkg)
+endif
+
+sum: $(src)
+ updpkgsums
+
+clean:
+ rm -rf $(inf) $(nam)-* *.tar.xz *.tar.gz pkg/ src/ *.part
+
+# vim: se ts=4:
diff --git a/PKGBUILD b/PKGBUILD
index 86f10baa2baf..fd3312afda83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Boris Momcilovic <boris.momcilovic@gmail.com>
# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
# Contributor: Elis Hughes <elishughes@googlemail.com>
+# Contributor: Mark Blakeney at bullet-systems dot net
pkgname=python-pssh
pkgver=2.3.1
-pkgrel=9
+pkgrel=10
pkgdesc="Parallel versions of the openssh tools ssh, scp, rsync, nuke, slurp"
arch=('any')
url="http://code.google.com/p/parallel-ssh/"
@@ -16,12 +17,14 @@ source=(https://storage.googleapis.com/google-code-archive-downloads/v2/code.goo
Imports-are-absolute-by-default-in-Python3.patch
pssh-typeerror-str-does-not-support-the-buffer-interface.patch
pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
- pssh-read-stdin-as-bytes-in-Python-3.patch)
+ pssh-read-stdin-as-bytes-in-Python-3.patch
+ Relative-paths-should-be-allowed.patch)
sha256sums=('539f8d8363b722712310f3296f189d1ae8c690898eca93627fc89a9cb311f6b4'
'12257c60e7db3d152f0b3307d0cd0263a95bddfc856aa570908a0491a1a03c56'
'6b4574810b09f4ca855b81a036643aa27613ea69e1cd92755b9b9f155985d332'
'40b01fd5c2aa59542a5d1bf65a41b861733f71305a9799c1d1ca6661f228a891'
- '47c1af738d4ba252e9f35c5633da91bae2a2919a7b6b2bf425ee1f090d61c7fe')
+ '47c1af738d4ba252e9f35c5633da91bae2a2919a7b6b2bf425ee1f090d61c7fe'
+ '3ba2ec624ac2aa3dbd832311ade97b65ab389b4b4aa55a4b672447809c7b463a')
prepare() {
cd "${srcdir}"/pssh-$pkgver
@@ -34,6 +37,8 @@ prepare() {
patch -Np0 -i ../pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
# fix FS#5153
patch -Np1 -i ../pssh-read-stdin-as-bytes-in-Python-3.patch
+# fix to allow relative paths
+ patch -Np1 -i ../Relative-paths-should-be-allowed.patch
}
package() {
diff --git a/Relative-paths-should-be-allowed.patch b/Relative-paths-should-be-allowed.patch
new file mode 100644
index 000000000000..c129a2a7cc3c
--- /dev/null
+++ b/Relative-paths-should-be-allowed.patch
@@ -0,0 +1,84 @@
+From 887b49452acfa897e700083fe732f1b24788f1d8 Mon Sep 17 00:00:00 2001
+From: Mark Blakeney <mark.blakeney@bullet-systems.net>
+Date: Tue, 21 May 2019 09:24:56 +1000
+Subject: [PATCH] Relative paths should be allowed
+
+This applies the fix for https://code.google.com/archive/p/parallel-ssh/issues/83.
+---
+ bin/prsync | 4 ----
+ bin/pscp | 6 +-----
+ bin/pslurp | 5 +----
+ 3 files changed, 2 insertions(+), 13 deletions(-)
+
+diff --git a/bin/prsync b/bin/prsync
+index 84130af..354e225 100755
+--- a/bin/prsync
++++ b/bin/prsync
+@@ -7,7 +7,6 @@
+ """Parallel rsync to the set of nodes in hosts.txt.
+
+ For each node, we essentially do a rsync -rv -e ssh local user@host:remote.
+-Note that remote must be an absolute path.
+ """
+
+ import os
+@@ -110,9 +109,6 @@ if __name__ == "__main__":
+ opts, args = parse_args()
+ local = args[0]
+ remote = args[1]
+- if not re.match("^/", remote):
+- print("Remote path %s must be an absolute path" % remote)
+- sys.exit(3)
+ try:
+ hosts = psshutil.read_host_files(opts.host_files,
+ default_user=opts.user)
+diff --git a/bin/pscp b/bin/pscp
+index 5b89b70..75bf449 100755
+--- a/bin/pscp
++++ b/bin/pscp
+@@ -7,8 +7,7 @@
+ """Parallel scp to the set of nodes in hosts.txt.
+
+ For each node, we essentially do a scp [-r] local user@host:remote. This
+-program also uses the -q (quiet) and -C (compression) options. Note that
+-remote must be an absolute path.
++program also uses the -q (quiet) and -C (compression) options.
+ """
+
+ import os
+@@ -92,9 +91,6 @@ if __name__ == "__main__":
+ opts, args = parse_args()
+ localargs = args[0:-1]
+ remote = args[-1]
+- if not re.match("^/", remote):
+- print("Remote path %s must be an absolute path" % remote)
+- sys.exit(3)
+ try:
+ hosts = psshutil.read_host_files(opts.host_files,
+ default_user=opts.user)
+diff --git a/bin/pslurp b/bin/pslurp
+index c7dece6..8a73124 100755
+--- a/bin/pslurp
++++ b/bin/pslurp
+@@ -8,7 +8,7 @@
+
+ For each node, we essentially do a scp [-r] user@host:remote
+ outdir/<node>/local. This program also uses the -q (quiet) and -C
+-(compression) options. Note that remote must be an absolute path.
++(compression) options.
+ """
+
+ import os
+@@ -113,9 +113,6 @@ if __name__ == "__main__":
+ opts, args = parse_args()
+ remote = args[0]
+ local = args[1]
+- if not re.match("^/", remote):
+- print("Remote path %s must be an absolute path" % remote)
+- sys.exit(3)
+ try:
+ hosts = psshutil.read_host_files(opts.host_files,
+ default_user=opts.user)
+--
+2.21.0
+