summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbb132e230da..df43896ad096 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = python-pwntools-git
- pkgdesc = A CTF framework and exploit development library. (git branch dev3)
- pkgver = 3.13.0beta0.r199.gb0e1ce33
+ pkgdesc = A CTF framework and exploit development library. (git branch dev)
+ pkgver = 4.9.0beta0.r1.g7f5866ab
pkgrel = 1
url = https://github.com/Gallopsled/pwntools
arch = any
license = GPL
makedepends = make
+ makedepends = git
depends = python
depends = python-intervaltree
depends = python-pyelftools
depends = python-tox
depends = python-mako
- depends = python-unicorn
+ depends = python-unicorn-git
depends = python-psutil
depends = python-dateutil
depends = python-pysocks
@@ -23,12 +24,13 @@ pkgbase = python-pwntools-git
depends = python-capstone
depends = python-requests
depends = python-psutil
- depends = python-pypandoc
depends = python-packaging
+ depends = python-rpyc
+ depends = python-colored-traceback
optdepends = gdb: binary debugging
provides = python-pwntools
- source = python-pwntools-git::git+https://github.com/Gallopsled/pwntools.git#branch=dev3
+ conflicts = python-pwntools
+ source = python-pwntools-git::git+https://github.com/Gallopsled/pwntools.git#branch=dev
sha256sums = SKIP
pkgname = python-pwntools-git
-
diff --git a/PKGBUILD b/PKGBUILD
index cdac22e96ac2..12dd82c92b2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Aaron McDaniel (mcd1992) <'aur' at the domain 'fgthou.se'>
-
+# Maintainer: Lahfa Samy (AkechiShiro) <'akechishiro-aur' at the domain 'lahfa.xyz'>
+# Contributor: Aaron McDaniel (mcd1992) <'aur' at the domain 'fgthou.se'>
pkgname=python-pwntools-git
-pkgver=3.13.0beta0.r199.gb0e1ce33
+pkgver=4.9.0beta0.r1.g7f5866ab
pkgrel=1
-pkgdesc='A CTF framework and exploit development library. (git branch dev3)'
+pkgdesc='A CTF framework and exploit development library. (git branch dev)'
url='https://github.com/Gallopsled/pwntools'
arch=('any')
license=('GPL')
-makedepends=('make')
+makedepends=('make' 'git')
+conflicts=('python-pwntools')
depends=('python' 'python-intervaltree' 'python-pyelftools' 'python-tox' 'python-mako'
- 'python-unicorn' 'python-psutil' 'python-dateutil' 'python-pysocks' 'python-pygments'
+ 'python-unicorn-git' 'python-psutil' 'python-dateutil' 'python-pysocks' 'python-pygments'
'python-pip' 'python-pyserial' 'python-paramiko' 'ropgadget' 'python-capstone'
- 'python-requests' 'python-psutil' 'python-pypandoc' 'python-packaging')
+ 'python-requests' 'python-psutil' 'python-packaging' 'python-rpyc' 'python-colored-traceback')
optdepends=('gdb: binary debugging')
-source=("${pkgname}::git+https://github.com/Gallopsled/pwntools.git#branch=dev3")
+source=("${pkgname}::git+https://github.com/Gallopsled/pwntools.git#branch=dev")
sha256sums=('SKIP')
provides=('python-pwntools')
@@ -25,8 +26,6 @@ pkgver() {
prepare() {
cd ${pkgname}
- #sed -i "s/'sortedcontainers<2.0'/'sortedcontainers'/" setup.py
- #sed -i "s/'intervaltree<3.0'/'intervaltree'/" setup.py
}
build() {