summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ad07d3f84d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pyassimp
+ pkgdesc = Portable Open Source library to import various well-known 3D model formats in an uniform manner. Python bindings.
+ pkgver = 3.1.1
+ pkgrel = 1
+ url = http://assimp.sourceforge.net/index.html
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = assimp
+ depends = python>=3
+ conflicts = python2-pyassimp
+ source = https://github.com/assimp/assimp/archive/v3.1.1.tar.gz
+ md5sums = ab9977edf95e9b2910d7cca286926e85
+
+pkgname = python-pyassimp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acf4c7656803
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: jepaan <jepaan at hotmail dot com>
+
+pkgname=python-pyassimp
+_name=assimp
+pkgver=3.1.1
+pkgrel=1
+pkgdesc="Portable Open Source library to import various well-known 3D model formats in an uniform manner. Python bindings."
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('assimp' 'python>=3')
+url=('http://assimp.sourceforge.net/index.html')
+source=("https://github.com/assimp/assimp/archive/v${pkgver}.tar.gz")
+md5sums=('ab9977edf95e9b2910d7cca286926e85')
+conflicts=(python2-pyassimp)
+
+build()
+{
+ cd ${srcdir}/${_name}-${pkgver}/port/PyAssimp
+ python3 setup.py build
+}
+
+package()
+{
+ cd ${srcdir}/${_name}-${pkgver}/port/PyAssimp
+ python3 setup.py install --root="$pkgdir/" --optimize=1
+}