summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD30
3 files changed, 22 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46b4dc45cd7c..5c54998cf388 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = python-pydes
pkgdesc = Pure python implementation of DES and TRIPLE DES encryption algorithm
pkgver = 2.0.1
- pkgrel = 6
- url = https://pypi.org/project/pyDes/
+ pkgrel = 4
+ url = https://github.com/twhiteman/pyDes
arch = any
license = MIT
+ makedepends = git
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
depends = python
- source = pyDes-2.0.1.tar.gz::https://files.pythonhosted.org/packages/source/p/pyDes/pyDes-2.0.1.tar.gz
- b2sums = 45a2d0575519afc389abe080f2c3a6751c5ee1f973e9e4370f24c5dbf9d85882e875682005eae3d749a2e11bffc3cd46868f83baa58f9e7e4feb7a25db641a14
+ source = pyDes::git+https://github.com/twhiteman/pyDes#commit=e988a5ffc9abb8010fc75dba54904d1c5dbe83db
+ b2sums = 5c717ca1d8600403a2c6c36134001b9fbd211b9bb74580a697e8434c51ddacbbf661ae1df6bec2cf1871244fe88c6f7ecf24711c26ed97c2e1f51b3215f5c8cf
pkgname = python-pydes
diff --git a/.gitignore b/.gitignore
index 92058b028e45..7046f5d40a7f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,3 @@
+pyDes
*.tar.*
*.log
diff --git a/PKGBUILD b/PKGBUILD
index 128316c0b930..6f3b5b17828a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
_pkgname=pyDes
pkgname=python-pydes
+_commit=e988a5ffc9abb8010fc75dba54904d1c5dbe83db
pkgver=2.0.1
-pkgrel=6
+pkgrel=4
pkgdesc="Pure python implementation of DES and TRIPLE DES encryption algorithm"
-arch=('any')
-url="https://pypi.org/project/pyDes/"
-license=('MIT')
-depends=('python')
+arch=(any)
+url=https://github.com/twhiteman/pyDes
+license=(MIT)
+depends=(python)
makedepends=(
- 'python-build'
- 'python-installer'
- 'python-setuptools'
- 'python-wheel'
+ git
+ python-build
+ python-installer
+ python-setuptools
+ python-wheel
)
-source=("${_pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-$pkgver.tar.gz")
-b2sums=('45a2d0575519afc389abe080f2c3a6751c5ee1f973e9e4370f24c5dbf9d85882e875682005eae3d749a2e11bffc3cd46868f83baa58f9e7e4feb7a25db641a14')
+source=($_pkgname::git+https://github.com/twhiteman/pyDes#commit=$_commit)
+b2sums=('5c717ca1d8600403a2c6c36134001b9fbd211b9bb74580a697e8434c51ddacbbf661ae1df6bec2cf1871244fe88c6f7ecf24711c26ed97c2e1f51b3215f5c8cf')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd $_pkgname
python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd $_pkgname
python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}