summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..062799b28ba1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-pyelliptic
+ pkgdesc = Python OpenSSL wrapper. For modern cryptography with ECC, AES, HMAC, Blowfish...
+ pkgver = 1.5.8
+ pkgrel = 1
+ url = https://github.com/yann2192/pyelliptic
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = openssl
+ source = https://github.com/yann2192/pyelliptic/archive/1.5.8.tar.gz
+ sha256sums = ec23fb3a39a9ad9402354c2ac6c66990e737435365eb313070dd9a76e6849153
+
+pkgname = python2-pyelliptic
+ provides = python2-pyelliptic=1.5.8
+
+pkgname = python-pyelliptic
+ provides = python-pyelliptic=1.5.8
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8857cb9c69f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: robertfoster
+
+pkgbase=python-pyelliptic
+pkgname=('python2-pyelliptic' 'python-pyelliptic')
+_pkgname=pyelliptic
+pkgver=1.5.8
+pkgrel=1
+pkgdesc="Python OpenSSL wrapper. For modern cryptography with ECC, AES, HMAC, Blowfish..."
+arch=(any)
+url="https://github.com/yann2192/pyelliptic"
+license=('GPL3')
+depends=('openssl')
+makedepends=('python-setuptools')
+source=(https://github.com/yann2192/pyelliptic/archive/$pkgver.tar.gz)
+
+build() {
+ cp -a ${_pkgname}-${pkgver}{,-py2}
+
+ cd ${_pkgname}-${pkgver}
+ python setup.py build
+
+ cd ../${_pkgname}-${pkgver}-py2
+ python2 setup.py build
+}
+
+package_python-pyelliptic(){
+ provides=("$pkgname=$pkgver")
+ cd ${_pkgname}-${pkgver}
+ python setup.py install --root="$pkgdir" --skip-build
+}
+
+package_python2-pyelliptic(){
+ provides=("$pkgname=$pkgver")
+ cd ${_pkgname}-${pkgver}-py2
+ python2 setup.py install --root="$pkgdir" --skip-build
+}
+
+sha256sums=('ec23fb3a39a9ad9402354c2ac6c66990e737435365eb313070dd9a76e6849153')