summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b69becd656dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pyfdt
+ pkgdesc = Python flattened device tree parser
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/superna9999/pyfdt
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/p/pyfdt/pyfdt-0.3.tar.gz
+ sha512sums = f66cfa3fd5b8a49334464a6dc8a2cb3d99e8e4a521b04a39a2dda32fdbedba4420be91b28533f7421c28ea1a98b240f1b3d753a0311bcaed76f7005016e59090
+
+pkgname = python-pyfdt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5203b1d6c97d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sean Anderson <seanga2@gmail.com>
+pkgname=python-pyfdt
+_name=${pkgname#python-}
+pkgver=0.3
+pkgrel=1
+pkgdesc="Python flattened device tree parser "
+arch=('any')
+url="https://github.com/superna9999/pyfdt"
+license=('Apache')
+groups=()
+depends=('python')
+makedepends=('python-setuptools')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha512sums=('f66cfa3fd5b8a49334464a6dc8a2cb3d99e8e4a521b04a39a2dda32fdbedba4420be91b28533f7421c28ea1a98b240f1b3d753a0311bcaed76f7005016e59090')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}