summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54fc0217a8cf..359c7df15c8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,25 @@
pkgbase = python-pygmo
pkgdesc = Perform parallel computations of optimisation tasks (global and local) via the asynchronous generalized island model (Python version)
- pkgver = 2.13.0
+ pkgver = 2.14.0
pkgrel = 1
- url = https://esa.github.io/pagmo2/index.html
+ url = https://esa.github.io/pygmo2/
arch = i686
arch = x86_64
license = GPLv3
makedepends = cmake
+ makedepends = python
+ makedepends = pybind11
+ makedepends = pagmo
+ makedepends = boost
depends = python
depends = boost
depends = pagmo
depends = python-numpy
depends = python-cloudpickle
- source = https://github.com/esa/pagmo2/archive/v2.13.0.tar.gz
- sha512sums = c33069abd513454777a9cc8df24437c7feba2ec64c20b0b123e9cf92cb9877553cd67b1b55c9252d65a1d9ee204492911c3b17a32140a2176694c694f27d9287
+ optdepends = python-matplotlib
+ optdepends = python-dill
+ source = https://github.com/esa/pygmo2/archive/v2.14.0.tar.gz
+ sha256sums = 72000a0c6bd22b8955a65ebfcb53a8f42e8b00fd16afc0b7b43ef74b14883d60
pkgname = python-pygmo
diff --git a/PKGBUILD b/PKGBUILD
index 739a78ee42f0..6c498f93734a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=python-pygmo
-pkgver=2.13.0
+pkgver=2.14.0
pkgrel=1
pkgdesc="Perform parallel computations of optimisation tasks (global and local) via the asynchronous generalized island model (Python version)"
arch=('i686' 'x86_64')
-url="https://esa.github.io/pagmo2/index.html"
+url="https://esa.github.io/pygmo2/"
license=('GPLv3')
depends=('python' 'boost' 'pagmo' 'python-numpy' 'python-cloudpickle')
-optdepends=()
-makedepends=('cmake')
-_name=pagmo2
+optdepends=('python-matplotlib' 'python-dill')
+makedepends=('cmake' 'python' 'pybind11' 'pagmo' 'boost')
+_name=pygmo2
source=(https://github.com/esa/${_name}/archive/v${pkgver}.tar.gz)
-sha512sums=('c33069abd513454777a9cc8df24437c7feba2ec64c20b0b123e9cf92cb9877553cd67b1b55c9252d65a1d9ee204492911c3b17a32140a2176694c694f27d9287')
+sha256sums=('72000a0c6bd22b8955a65ebfcb53a8f42e8b00fd16afc0b7b43ef74b14883d60')
_buildtype="Release"
@@ -29,8 +29,6 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE="${buildtype}" \
-DCMAKE_INSTALL_PREFIX="/usr" \
- -DPAGMO_BUILD_PAGMO=OFF \
- -DPAGMO_BUILD_PYGMO=ON \
"${srcdir}/${_name}-${pkgver}"
msg "Building the project"